Results 1 to 8 of 8
  1. #1

    help with instaling engine

    hey all need some info got all teh cables and what not but i cant seem to find where the hose for the flush goes and i am was reading somewhere that engine has to be aligned ????
    i thougt this was preety straight foward but now i am getting a little worried that i might be doing something wrong any help will be good


  2. #2
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    You should be worried. Engine alignment is crucial.

    Start by reading this thread
    http://www.greenhulk.net/forums/showthread.php?t=46618

  3. #3
    ive read the whole thing and there is nothing on there about engine elignment ??? i am missing something

  4. #4
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Here is another. You may want to browse the How To / FAQ section
    http://www.greenhulk.net/forums/show...ight=alignment

  5. #5
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by josh_m View Post
    ive read the whole thing and there is nothing on there about engine elignment ??? i am missing something
    Yeah... a $500 alignment tool

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by josh_m View Post
    hey all need some info got all teh cables and what not but i cant seem to find where the hose for the flush goes and i am was reading somewhere that engine has to be aligned ????
    i thougt this was preety straight foward but now i am getting a little worried that i might be doing something wrong any help will be good
    As long as you didn't disturb the engine mounts (remove or add shims) and just unbolted the engine the alignment won't be that crucial.

    The flush port hose connects to the pump shoe and connects at the other end to the top of the J pipe.

    Hope that helps!

  7. #7
    the only mount that was removed was the front one but the rest were still in place , would that make a diffrence

  8. #8
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by josh_m View Post
    the only mount that was removed was the front one but the rest were still in place , would that make a diffrence
    That's the worst one!!! An alignment is highly recommended... my .02

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help with new engine install.... 1st start on xlt 1200
    By DieselNaz in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 08-17-2015, 01:17 AM
  2. Urgent help with rebuilt engine
    By josh_m in forum 4-Tec Performance
    Replies: 9
    Last Post: 01-08-2010, 12:45 PM
  3. Need Help With 951 Engine
    By turbocycle in forum 2-Stroke Performance
    Replies: 6
    Last Post: 07-04-2008, 07:33 AM
  4. help with new engine mods
    By RxPrider in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-22-2008, 01:16 PM
  5. help with installing oil block off kit
    By joshxp in forum Polaris Open Discussion
    Replies: 4
    Last Post: 03-30-2007, 11:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •