Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,570
    +1
    112

    RR ECU Install questions

    I now have the Rotax Racing ECU and am thinking of installing it on my 2005 RXP. But, have a few questions ...

    My 'wrapper' says 4501 - is this the right 'rich' race ECU? I don't want the 'stock class legal' ECU since I already have the RR IC.

    I need to cut out my knock sensor 'rectumfier' from the wiring and splice in a length of wire since mine is an '05. Does this effectively eliminate the knock sensor from operating, or just change its operation by removal of that long black skinny cigar looking thing from the wiring?

    I need to GPS again, but am turning my PPG pitched 14/19 8150 rpms most days now. I have the Riva air filter, PPG power pipe, RR Intercooler, 158 deg thermostat, Riva grate and wedge. I am getting about 72 mph GPS currently, but have not touched the ride plate or anything. So, is installing the ECU worth it? How much should I gain on top end?

    Anybody have problems or regret installing their race ECU? For awhile it seemed like it might be causing some problems for some of you ...


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,961
    +1
    1,887
    Im not sure how to modify the harness on the 05's, but im sure Mark Underwood could walk you thru it.

    You should gain between 1 and 2 mph with the ECU.

    The ECU you have is the correct "race" ECU

  3. #3
    Jerry, so assuming that someone has an 04 rxp that has not had the knock sensor update done. Can they pass on getting the knock sensor done and just get the racing ecu instead?

  4. #4
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    9,367
    +1
    623
    I say yes, since your knock sensor update is a piggy back harness and needs to be removed for the RR ECU install.

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,961
    +1
    1,887
    Yes!

  6. #6

    Join Date
    Jun 2005
    Location
    Cayman Islands
    Posts
    705
    Hey Guys I just installed a RR ECU for a freind we called PPG about this and they told me that theres no need to remove the harness (Knock sensor upgrade) with the new ECU's.

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,961
    +1
    1,887
    Who at PPG told you this?

  8. #8
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,254
    +1
    846
    you are right about not removing the harness if you are running a new stock class ecu, that is teh reason we were all having these problems with the new ones, because the directions with the ecu said remove it, and we did not need to, which i just found out from gp yesterday, teh rich one however i do believe you have to modify the harness,

    to do this if you follow your knock sensor harness from behind teh ecu to the front of the boat you will see about a 5 inch long by 1/2" tube in the harness, you will need to remove this and reconnect the wires, let me know if you need to know what colors need to be connected to each other and i can look it up, its very easy to do, just remove you engine cowling, and make sure you seal up the connection really good, it took me about 15 minutes to do on my ski,

  9. #9

    Join Date
    Jun 2005
    Location
    Cayman Islands
    Posts
    705
    Quote Originally Posted by Green Hulk
    Who at PPG told you this?
    Fraser.

  10. #10
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,961
    +1
    1,887
    Just to clarify, for the Rotax Racing "stock class" ECU you leave the piggy back harness in place.

    For the Rotax Racing ECU you must remove the piggy back harness if the knock sensor update was done in an 04 model, or you must modify the wire harness in the 05 model.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva stage II install question
    By RXPNJ in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-18-2006, 09:07 PM
  2. SC install questions
    By Vern in forum 4-Tec Performance
    Replies: 10
    Last Post: 04-01-2006, 01:26 PM
  3. bov kit install question
    By TroyRXP15 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-15-2005, 09:16 PM
  4. Pump install question.
    By Mark S in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-01-2005, 09:25 PM
  5. '05 RXT/GTX RR IC install question... O-ring?
    By 05Limited in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-03-2005, 09:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •