Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1

    Join Date
    Feb 2006
    Location
    Florida
    Posts
    101

    need help, jetski dies after take off

    Hey everyone,
    I got a problem with my xl1200 1999. Ski idles fine but when I take off it will go about 200 yards and then die. it will not start right away, but if I let it sit for about 30 seconds or more it will start right up and it will do it all over again. Does anyone have any ideas what might be the problem.

    Thanks, ybnormal


  2. #2

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9
    sounds like fuel problem,time to clean carb's,86 fuel valve might as well install some mod's while in there

    later cd

  3. #3

    Join Date
    Feb 2006
    Location
    Florida
    Posts
    101
    Hey Chip,
    carbs were just rebuilt. after it dies out it will not start right up you can hit the start button and it will not turn over, you can here the starter kick in but nothing. If I wait for about 30 seconds or more it will start and do it all over again.

    Thanks yb

  4. #4

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374
    check the battery cables might be loose or dirty
    Mike

  5. #5

    Join Date
    Feb 2006
    Location
    Florida
    Posts
    101
    will do mike, I did just put a new battery in last night.

    Thanks, yb

  6. #6

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9
    well that sounds like starter drive,you'll have to pull front cover for that/how many things wrong with this ski?
    boat=break out another thousand

    later cd

  7. #7

    Join Date
    Feb 2006
    Location
    Florida
    Posts
    101
    chip don't think it is a starter, as the engine is dying under a load

    thanks, yb

  8. #8

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9
    I hope motor's not sticking on you,how's sparkplug look?

  9. #9
    GPR FL's Avatar
    Join Date
    Aug 2005
    Location
    Raleigh, NC
    Posts
    162
    +1
    1
    Where in Fl r u?

  10. #10

    Join Date
    Feb 2006
    Location
    Florida
    Posts
    101
    hey Chip,
    Plugs look good, I did replace them when I was at the water this morning. The old ones even looked good.

    Hey GPR, I live in Perry florida its about an hour east of Tallahassee

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with 03 GTX shutting off at WOT
    By 03gtx in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 04-09-2014, 11:40 PM
  2. Need help finding a part; Shut-off valve for Visibility Spout hose
    By DrivingZiggy in forum Yamaha PWC Performance (4-stroke)
    Replies: 37
    Last Post: 02-19-2014, 10:48 PM
  3. Replies: 9
    Last Post: 07-05-2010, 06:36 PM
  4. Need help with RE's block offs
    By BlackHawk in forum 4-Tec Performance
    Replies: 45
    Last Post: 12-06-2009, 04:03 PM
  5. need help with oil injection block off 2006 gp1300rs
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-06-2007, 11:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •