Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 50
  1. #1
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673

    Riva Waterbox Installation

    Well the time has finally come

    Removed the J pipe and WTF happend here

    I just had the pipe off like 5-6 hrs. ago and everything looked fine

    What are my options here... or should I say "whats this gonna cost me"
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSCF2176.JPG 
Views:	111 
Size:	2.52 MB 
ID:	108804  


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    that's a pretty normal sight when you yank the J pipe off the manifold.

    Aluminum + Heat = erosion

    Actually, yours isn't that bad. If you were running real lean it would look way worse than that.

  3. #3
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by bigdaddyRXP View Post
    Well the time has finally come

    Removed the J pipe and WTF happend here

    I just had the pipe off like 5-6 hrs. ago and everything looked fine

    What are my options here
    ... or should I say "whats this gonna cost me"
    HEADERS

  4. #4
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by Green Hulk View Post
    that's a pretty normal sight when you yank the J pipe off the manifold.

    Aluminum + Heat = erosion

    Actually, yours isn't that bad. If you were running real lean it would look way worse than that.
    So... your saying its normal... run it like it is

  5. #5
    Quote Originally Posted by bigdaddyRXP View Post
    So... your saying its normal... run it like it is
    Pull the manifold and send it off to whoever does the SS tip mod on here. http://greenhulk.net/forums/showthre...+manifold+bell

  6. #6
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6
    I wish the bell looked that good on my manifold. I ran all season with the tip totally burnt off with no ill effects. probably gave me 2hp extra

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by bigdaddyRXP View Post
    So... your saying its normal... run it like it is
    Run it and don't worry about it

  8. #8
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by dhoad View Post
    I wish the bell looked that good on my manifold. I ran all season with the tip totally burnt off with no ill effects. probably gave me 2hp extra
    Why not just cut it off then

    May add 6hp

  9. #9
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by Green Hulk View Post
    Run it and don't worry about it
    Good enough for me... thanks Jerry!

  10. #10
    mitch411 does the manifold mod, i have 1, he has a couple allready done up just shoot him a pm for info

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva Waterbox Install
    By Sea-Yaa in forum 4-Tec Performance
    Replies: 19
    Last Post: 04-01-2016, 12:24 PM
  2. Riva Pro waterbox install
    By RXP_Noah in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-26-2011, 10:08 PM
  3. Riva waterbox install any tips?
    By bblades262 in forum 4-Tec Performance
    Replies: 1
    Last Post: 02-17-2010, 01:28 PM
  4. Riva Pro-Series Waterbox Install
    By RXTMAN in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-04-2009, 10:04 PM
  5. Riva IC install in a GTX SC...
    By Pale Rider in forum 4-Tec Performance
    Replies: 38
    Last Post: 09-08-2007, 08:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •