Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1

    skip, question with a 250x

    Skip, got a question with a 250x of my friend. His supercharger is heating up. Have you experienced this kind of problem already? when you pour water in the supercharger housing it sizzles. What could the problem be?


  2. #2
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,563
    +1
    169
    Quote Originally Posted by timmy_philson View Post
    Skip, got a question with a 250x of my friend. His supercharger is heating up. Have you experienced this kind of problem already? when you pour water in the supercharger housing it sizzles. What could the problem be?

    has he checked the oil level in the supercharger?

  3. #3
    yes, he checked the oil level, hose leaks, tension of the belt, the ol level of the engine and many more. Have you encountered this kind of problem region8?

  4. #4
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,563
    +1
    169
    Quote Originally Posted by timmy_philson View Post
    yes, he checked the oil level, hose leaks, tension of the belt, the ol level of the engine and many more. Have you encountered this kind of problem region8?
    not really generally i am not checking the temp of the blower....i check the oil level and thats about it.

    is there anything done to the boat?

  5. #5
    Dan, its a stock ultra and the blower is too hot you just use it for 15 mins and its sizzling already and after 30 mins the overheat warning shows up already.

  6. #6
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,563
    +1
    169
    Quote Originally Posted by timmy_philson View Post
    Dan, its a stock ultra and the blower is too hot you just use it for 15 mins and its sizzling already and after 30 mins the overheat warning shows up already.

    something is clogging the cooling system... i had the overheat issue and it was a lack of water flow.

    is it a fresh or saltwater boat? is it flushed regularly.... if it is getting hot that quickly there is a cooling issue that needs to be addressed

  7. #7
    there is no cooling system going to the supercharger blower thou. but i will tell him to check it. thanks Dan.

  8. #8
    I have had this happen on a blower with a bad bearing. Heat up behind the pulley and the thing damn near boils off the boat.

    He may or may not have done internal damage to the charger. I can pull the bearing if it is out of warranty to check it but more then likely the charger is now locked up now that it has cooled off.


    Foggy but my crystal ball says bad front drive bearing.

  9. #9
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,992
    +1
    455
    Quote Originally Posted by Skips313 View Post
    I have had this happen on a blower with a bad bearing. Heat up behind the pulley and the thing damn near boils off the boat.

    He may or may not have done internal damage to the charger. I can pull the bearing if it is out of warranty to check it but more then likely the charger is now locked up now that it has cooled off.


    Foggy but my crystal ball says bad front drive bearing.
    Bearings replaceable on the unit?

  10. #10
    Skip, I just found out that the supercharger is a new supercharger with just 30 mins of use. with new bearings and pulley. He changed the blower coz he had the same problem before and his mechanic checked and found that the rotors were worn out already. So they ordered a new one and installed it to the ultra. As of now all of the components of the blower is brand new and it still overheats. I cantf figure out what and where the problem is.

    Hi Blue, yup the bearings can be replaced. I was able to do that already.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. quick question with jetworks mod.
    By dogger in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 05-03-2007, 09:25 PM
  2. question on ultra 250x impeller tool
    By XRIDER in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 04-18-2007, 07:29 AM
  3. something wrong with my 250x
    By born riding in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 04-15-2007, 11:08 PM
  4. Questions with pictures attached
    By MikeB in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 02-16-2007, 11:31 PM
  5. impeller questions.. with pictures
    By jcc011185 in forum Polaris PWC Performance
    Replies: 22
    Last Post: 09-27-2006, 02:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •