Results 1 to 7 of 7
  1. #1

    Installed new ride plate inserts.

    Installed some new Yamaha OEM ride plate inserts. Removed the old sealant and cleaned the area with acetone, as well as the inserts. I masked the area`s off bc the ride plate is installed temporarily and don`t want the sealant oozing thru the hull and onto the plate. I used DOW 795 sealant. Torqued the bolts to 10# to seat the inserts. It is not necc to use 5200 for these. If another bolt breaks or hole gets stripped out it can be removed. The plate will be sealed upon final installation.
    Last edited by Pale Rider; 01-19-2010 at 05:24 PM.


  2. #2
    African-American
    Join Date
    Feb 2007
    Location
    Cape Town, South Africa
    Posts
    2,226
    +1
    88
    the tunnel reinforcement looks factory

  3. #3
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    did you have a broken bolt in it before?

  4. #4
    Quote Originally Posted by OsideBill View Post
    did you have a broken bolt in it before?
    sure did Bill. three came out with very little fuss, and the last one well, the head just popped off with very little effort, go figure...

  5. #5
    Quote Originally Posted by spaceman View Post
    the tunnel reinforcement looks factory
    Thank You!

  6. #6
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    I toss the factory bolts and go with SST allen caps and SST washers, install with antiseize and Iv'e never had an issue with them. Do the same with the Pump shoe and intake grate.

  7. #7
    Quote Originally Posted by OsideBill View Post
    I toss the factory bolts and go with SST allen caps and SST washers, install with antiseize and Iv'e never had an issue with them. Do the same with the Pump shoe and intake grate.
    absolutely, already on it, just got my hardware in. this was the OEM bolts that broke. First time the ride plate has been off, surprising for only 50 hours, no salt or anything, just snapped clean... oh well it`s over now...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97-99 GP1200 Ride Plate Insert Upgrade
    By OsideBill in forum Yamaha Old School Skis
    Replies: 44
    Last Post: 04-25-2016, 05:06 PM
  2. 15F - Installed new ride plate, now this
    By kawa900stx in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 07-31-2013, 05:56 PM
  3. Replies: 27
    Last Post: 07-09-2012, 09:33 PM
  4. what happened to new ride plate?
    By jeff007 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 03-10-2006, 10:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •