Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    txgp1300r's Avatar
    Join Date
    Apr 2006
    Location
    Dallas , Texas
    Posts
    3,381
    +1
    165

    photo of yamahas fix for 03 hull

    just got it back from yamaha, this is how they fixed the pump shoe pulling out...the brackets look real strong, gonna test it soon............................ooops here is the photo
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	yamaha1300_021_162.jpg 
Views:	129 
Size:	687.2 KB 
ID:	5571  


  2. #2

    Join Date
    Nov 2005
    Location
    All over
    Posts
    716
    No picture???

  3. #3
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    hello dave, Did they also instal a pump seal kit, Or are you going to do it.

  4. #4
    Buaidh No Bas howestek's Avatar
    Join Date
    May 2005
    Location
    Louisiana
    Posts
    917
    Looks like one of your rideplate inserts could stand a little more epoxy?

  5. #5
    Pistonwash's Avatar
    Join Date
    Aug 2005
    Location
    Florida
    Posts
    3,595
    +1
    77
    Also..you see where the waterbox cmes to rest on the tower on the right? Put a piece of hydroturf or a good rubberized foam on there, to help deflect vibration away from your waterbox. The harmonics will distort the exhaust wave in the waterbox and you wil lose performance.

    Not really. But it will keep that tower from getting hammered/cracked if you glue a small piece of hydro or padding on there before you put the waterbox back on. Don't make it too thick either.

  6. #6
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Also..you see where the waterbox cmes to rest on the tower on the right? Put a piece of hydroturf or a good rubberized foam on there, to help deflect vibration away from your waterbox. The harmonics will distort the exhaust wave in the waterbox and you wil lose performance.
    Thats is a very good point to bring up Mike .
    When I did my tunnel reinforcement, I noticed wear on my waterbox mount just liek that.
    When I installed my waterbox back in place. I slid a 1/8"thick x 6"x8" square peice of rubber sheet under it to help cushion it and prevent anymore wear from taking place. Must do.

  7. #7
    ABBOTT's Avatar
    Join Date
    Jul 2005
    Location
    Birmingham, AL / Lay Lake
    Posts
    3,736
    +1
    96
    looks good, you might want to get a tube of 5200, and just go nuts on top and around those inserts. The only downfall to this would be that you might not be able to get them off again easily if you ever wanted to do a pump tunnel reinforcement kit to it. But you can always use Pistonwashes way in the "How-To" section---i think it can be done without having to take the brackets off--but not positive on that.

    Glad they took care of you without any lip.

  8. #8
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    yeah, I would definitely reinforce it while you have all the stuff out the back. Nows the time to do it.

    If you want, I can mail you a paper template of that tunnel. that way, all you have to do it lay it on the glass, trace with a sharpie and cut out.

    I can try scanning it if it will print full size upon download.

  9. #9
    txgp1300r's Avatar
    Join Date
    Apr 2006
    Location
    Dallas , Texas
    Posts
    3,381
    +1
    165
    yep ur right about the water box...It rubbed a very small hole in the side...i took it to the shop and tig welded it ( i have a miller aircrafter 330 tig)..I then took your advice before you gave it to me and siliconed a thick piece of rubber to the box where it rests on the hull tower..I have a carbon fiber kit but think ill take it out and see what it will do...finally got a pet tach so i will know whats going on.....moter blips to 7600 on the trailer..ill find out what it will do in about a week...way too windy here in texas right now...thanks for the advice........oh, by the way ,i bought a rive race filter box....i been doing heads and exhaust and completely forgot the intake......fercho reeds are next

  10. #10
    MR. SCOVILLE UNIT SUCKMYWAKE's Avatar
    Join Date
    Aug 2005
    Location
    ASTON, PENNSYLVANIA
    Posts
    2,836
    +1
    8
    i ordered over the winter the little rubber strap that holds the waterbox in place and also the little rubber part that goes under the waterbox. both from riva

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Recommended fix for this hull damage?
    By TheEngineer in forum 4-Tec Performance
    Replies: 7
    Last Post: 12-05-2013, 10:49 AM
  2. Welcome to the support section of the forum for MoTeC Yamaha kits.
    By Green Hulk in forum Yamaha ECU Support
    Replies: 7
    Last Post: 09-03-2009, 11:06 PM
  3. Choice of Spons for gp1300r hull?
    By ExciterGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 16
    Last Post: 01-21-2009, 02:50 PM
  4. What OIL for Yamaha FX 140 03 ???
    By hajenhajen in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-23-2008, 12:16 PM
  5. Need hull reinforcement kit for 03 gpr
    By akent in forum Yamaha PWC Performance (2-stroke)
    Replies: 20
    Last Post: 05-24-2007, 07:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •