Results 1 to 1 of 1
  1. #1
    Tony's Avatar
    Join Date
    May 2007
    North Carolina

    780 piston failure

    First, a little history. This is a 780 (0.50 OS) with about 30 hours on a WSM top end rebuild The ski lost power and wouldn't idle. It would start easily but wouldn't idle. I had to ride it about 3 miles back to the ramp and if IRC it was down about 6-800 rpm. Compression readings were 130,130,80. I finally got a chance to pull the cylinder and get a look at what had happened. The area between the rings on the intake side of piston has eroded away. The rings were basically intact and broke away during tear down. I picked the jug up from the machine shop today, a hone made it as good as new.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC00361.JPG 
Views:	57 
Size:	509.0 KB 
ID:	109721  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 780 piston/domes pics....not to good!
    By Tony in forum Polaris Open Discussion
    Replies: 19
    Last Post: 06-10-2007, 07:56 PM
  2. Cleaning case after piston failure? Best approach?
    By snowrunner in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-03-2007, 07:41 AM
  3. Piston Failure???
    By beerdart in forum Polaris Open Discussion
    Replies: 16
    Last Post: 03-13-2007, 08:04 AM
  4. 780 Piston Kit
    By BigDaddyPT in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 12-13-2006, 05:21 PM
  5. 65U Group K cylinder/piston failure.
    By Flying Scotsman in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 10-05-2006, 01:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts