Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    brodie312's Avatar
    Join Date
    Dec 2008
    Location
    Queensland, Australia
    Posts
    24

    Arrow Which ski should be faster?????

    hey all!!!!

    ive got a 1998 kawasaki Xi Sport 750cc

    my mate has a 1994 yamaha wave raider 701cc

    i bought my ski of a ski dealer and my mate also purchased his ski of the same guy!

    the dealer told me that my ski would have more acceleration than the yamaha and both skis would have similar top speed.

    BUT... wen my mate and i took our skis out last weekend my ski did not have much power!! (it still went and runs fine) but my mates yamaha has loads more acceleration and has a much greater higher speed than my ski!

    i rang my dealer but he is on holidays. so i figur ill put up a post on here to see if any of u guys might know??

    the only thing we thought of was maybe i need new carbs??? but they look fine from wat we could see but we dont know wat it looks like on the inside!

    sorry bout the long post but all and any help is appreciated

    cheers from Brodie


  2. #2
    thesepaperwings's Avatar
    Join Date
    May 2007
    Location
    South East Kansas
    Posts
    1,283
    +1
    1
    The xi should accel great and top out around 48-50. Get a GPS and see what your running.

  3. #3
    brodie312's Avatar
    Join Date
    Dec 2008
    Location
    Queensland, Australia
    Posts
    24
    Quote Originally Posted by thesepaperwings View Post
    The xi should accel great and top out around 48-50. Get a GPS and see what your running.


    hmmm.... so it should be quicker than the yami then ur saying??

    cause mine is real slugish of the mark i mean it still goes but just not that fast

  4. #4

    Join Date
    Feb 2008
    Location
    Australia
    Posts
    4
    Hey,

    Could be anything that's wrong; doesn't have to be the carbs.
    Yami rider could just have more skill.






    :P

  5. #5
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Could be an engine problem (carbs, compression, etc.) or it could be a pump problem. I'd climb under it and take a look at the impeller. If it's dinged up badly, or if there is too much clearance between the impeller and housing, that would cause poor acceleration. It could also be improper sealing around the pump/intake grate.

  6. #6
    thesepaperwings's Avatar
    Join Date
    May 2007
    Location
    South East Kansas
    Posts
    1,283
    +1
    1
    What does the tach say it's hitting? Does it feel like its spinning out on the bottom end? Before you rip into the carbs you should get in touch with the dealer because that might void what little warranty you might have. Those motors are pretty amazing and should last longer then the pump.

  7. #7

    Join Date
    Sep 2008
    Location
    YOU CAN'T SEE ME
    Posts
    300
    I say impeller or blade-to-housing clearancs excessive; If that is ok, run compression test; If that checks ok, plugs are next; Then go to carbs and fuel pump (do both while down).

  8. #8
    brodie312's Avatar
    Join Date
    Dec 2008
    Location
    Queensland, Australia
    Posts
    24
    Quote Originally Posted by BeyondHuman View Post
    Hey,

    Could be anything that's wrong; doesn't have to be the carbs.
    Yami rider could just have more skill.

    :P

    ha ha lol of course u had to post on this


    i got compression test done which came out at 141psi off each spark plug

  9. #9
    brodie312's Avatar
    Join Date
    Dec 2008
    Location
    Queensland, Australia
    Posts
    24
    ok i took a picture of the impeller and its pretty much 0.5mm all the way round so i dont think its the impeller!!



    Click image for larger version. 

Name:	DSC00124 - Copy.JPG 
Views:	52 
Size:	258.7 KB 
ID:	109957

  10. #10
    brodie312's Avatar
    Join Date
    Dec 2008
    Location
    Queensland, Australia
    Posts
    24
    Quote Originally Posted by brodie312 View Post
    ok i took a picture of the impeller and its pretty much 0.5mm all the way round so i dont think its the impeller!!



    Click image for larger version. 

Name:	DSC00124 - Copy.JPG 
Views:	52 
Size:	258.7 KB 
ID:	109957


    oops i pointed the arrows to the wrong bit!!!!


    look at the impellar behind it loooool my bad

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel range GP1300r vs GPRXP ? Which one will be faster?
    By Avi8tor in forum Conversion PWC Performance Skis
    Replies: 31
    Last Post: 08-26-2012, 06:48 AM
  2. which ski would be best?
    By rickyd in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 01-09-2012, 07:36 PM
  3. which ski should be faster???
    By brodie312 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 11
    Last Post: 01-01-2009, 12:27 AM
  4. If your ski was car, which would it be?
    By afcblink in forum Open Discussion
    Replies: 15
    Last Post: 01-21-2008, 09:46 PM
  5. Should my 03 Stage 1 be faster then 02 completly stock
    By DONALDBUCHANAN in forum Yamaha PWC Performance (2-stroke)
    Replies: 31
    Last Post: 07-19-2007, 06:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •