Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Smile OK need computer help

    Got the 2001 running after checking all then swapping out the computer and injectors with a matched set from scrap ski.Only problem is under the black cover capacitor # C-27 is burnt off ,I cleaned it off around it,Does anyone know what that particular cap. does,Is it part of engine management or ???????The ski runs fine with it in there ,anyone know if it is safe to run ski with C-27 out???Thanks and Happy New year>Marvin


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    So the EMM that does run the engine properly has C-27 burned?

    C usually designates a capacitor, not a resistor.

    Can you post a clear close-up photo of the burned area?

    I don't have an electrical schematic for the Ficht EMM, so I don't know exactly what that part does.

    BTW, if anyone does know where I could find internal schematics for the Polaris Ficht EMM, I would certainly like to see them.

  3. #3

    computer pics its

    sorry I meant cap.I got too far ahead of myself,Yes the bad computer with burnt c-27 runs fine, the other one that looks good will only run ski at idle!go figure??Thanks>Marvin
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	P1000096.JPG 
Views:	52 
Size:	3.78 MB 
ID:	110025   Click image for larger version. 

Name:	P1000098.JPG 
Views:	42 
Size:	3.48 MB 
ID:	110026  

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    I cannot quite make out the capacitor part number, but I am thinking that a good electronics repair shop would be able to find a replacement part, and solder it in place.

    Be careful cleaning up the circuit board. You want to be sure all the little bits of the old capacitor, and old solder particles, are cleaned out of there.

    Be careful about using any liquids on the board, as they will tend to wick under the coatings, where it can be hard to get it dried out. I would dry clean it with a tooth brush or similar, and avoid cleaning liquids as much as possible.

  5. #5

    Smile

    it says 106v on top then m040E does that sound right?? for a cap number? thanks .marvin i wonder what caused it to burn in first place???

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by mrjetskey View Post
    it says 106v on top then m040E does that sound right?? for a cap number?
    ...I wonder what caused it to burn in first place???
    Those numbers sound possible. As I said, take the whole thing into a good shop, that works on modern electronics repair, at the component level.

    As for why it failed, I would be guessing. When the part is replaced, it might blow again immediately when the engine starts, or it might work just fine.

    It is also possible that other parts have failed, but do not look damaged. A good electronics tech, given some time and motivation, could trace out the circuits and figure out how it works.

    It is probably easier to just replace that one part, and see if that fixes it. If not, then you can consider sending it to DFI Technologies, or having a local tech work on it.

  7. #7

    Smile

    Thanks I am going to send one to DFI no local techs ,maybe a welder or two(haha) but no one who can trouble shoot a board,like I said it worked fine in the ski it came out of and it works fine in ski I put it and the injectors in,however just like a older tv with boards if one or two caps go out ,then they start failing,I am suprised to see a ceramic cap burnt, maybe its plastic but it was in little pieces when I dug it out of gel.It is very thoughtful of polaris to use that soft gel instead of epoxy like seadoo uses,Thank you for all your help.I fired dfi an email and am going to send them the non working board and then this one if I have problems after installing cap in it.Thanks again>Marvin

  8. #8

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    with my experince of tinkering with broken car amps , your gonna wanna take that board out go along the circuts and see why it popped , or toss it and get a new computer

    maybe water got in it , maybe sumthing on down the line is what actually failed ,

    who knows

    also ground yourself before takeing it apart any futher

  9. #9

    Smile

    Whats funny is the DFI guy said it shouldnt work at all as thats the high end FICHT,so anyway to keep ya"ll up to date I sent the non working computer with no burnt spots to DFI,The one with burnt cap came from a parts ski which had a thrown rod,I guess the computer failure is what caused the rod to chunk since DFI said that cap was high speed injection.It is just nice to get it started on road to repair and to know for sure what was bad!!Thanks for your words of wisdom guys I'll sure remember how much ya'll helped Thanks Again>Marvin

  10. #10

    Smile

    Quote Originally Posted by 97sltx1050 View Post
    with my experince of tinkering with broken car amps , your gonna wanna take that board out go along the circuts and see why it popped , or toss it and get a new computer

    maybe water got in it , maybe sumthing on down the line is what actually failed ,

    who knows

    also ground yourself before takeing it apart any futher
    PS>>>I always use a ground strap when working on any type of computer!!Thanks for reminding me though ,good advice!!First off the new computers for them run around 2300.00 plus you need a dealer who still has the software(none around) has kept techs trained(polaris quit building PWC in 2004) and wants to work on a watercraft that parts are very expensive, little factory support etc!!! SO! OK I sent the original computer to dfi,Not the one that I saw had a burnt cap and still worked,They replaced one cap.#c-89, upgraded the emm software and presto it works just fine for 379.00,SO for any one who has a 1200 that starts but wont go past idle,and you have tested fuel pressure,TPS,and all other,try sending your computer to DFI.they can just test it for you,and or up-grade software!I didnt realize the newer kawasaki ficht is using the same type setup.I am suprised that the injectors dont leak around the seat,I for one really prefer a carb type setup for reliability,performance,and longetivity.What is the deal with polaris 1200 only having 50 hrs ,66 hrs,etc. and needing fuel pump,computer ,fuel regulator,etc.I guess thats why they quit selling watercraft.I for one have worked on polaris watercraft since 1992,there 4 wheelers (gotta love the ride and the electric 4 wheel drive)BUt they have always overcomplicated things ,like having a 400cc two stroke 400 4 wheeler that you needed to change lubricant in 7 places,or that on one rebuild That needed a piston ,waterpump,oil pump drive ,and a few other things (ok lots of)the parts alone came to 2600.00,THey ride great run great ,but are way overcomplicated or used to be.I for one own an older polaris slt 780 and my wife loves it,I rebuilt engine in 99 with wiseco pistons,and it is fast dependable ,rides great,and simple.I for one would rather have a carburated 1050 over a 1200 ficht anyday,But hey we each have our own opinions,>Marvin

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need computer help sending fxsho manual.
    By amadus98 in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 05-17-2013, 10:01 AM
  2. need computer help
    By stingray152003 in forum Open Discussion
    Replies: 17
    Last Post: 07-14-2011, 02:16 AM
  3. Need Computer HELP!!!!!
    By RXP-REX in forum Open Discussion
    Replies: 24
    Last Post: 07-11-2008, 02:07 PM
  4. OK, need help with the small stuff now
    By Smitty in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 05-13-2006, 01:55 PM
  5. OK Pine box derby experts - I need your help
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 11-16-2005, 04:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •