Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 32
  1. #1

    Still have a performance prob with 00 XP

    All last summer we tried to figure out a problem with the rebuilt 951 in my 00 XP.

    It is just like the TPS is not working. We get to 6K rev's and that is it maybe 6300 about 45-50 mph.

    Now every now and then all of a sudden the rave open all the way and pow full rpm's.

    We have a new rebuild motor from Water Worx in Florida
    A new MPEM
    Checked the TPS and it does the 5 volt thing right where it should.

    We cleaned the rave for good measure and best we can tell the exhaust rave like valve is working since it does allow every now and then the motor to full rev's.

    Any ideas???


  2. #2
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    welcome to the forum

  3. #3
    Take the rave caps completely and remove the springs too. Take the ski for a spin without the parts on the motor. Will be a turd on the bottom end, but still should hit 6800+ rpm

  4. #4
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Yes, check valve on RAVES is probably frozen, not allowing the RAVES to open. 6300 is the majic max rpm number when they aren't opening.
    Last edited by 96XPSS; 12-31-2008 at 07:52 AM.

  5. #5
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    Check the check valve going to the solenoid from the case. I have a similar problem and my check valve is stuck closed not allowing pressure to the rave solenoid which in turn opens the rave. Almost the same symptoms.

  6. #6
    Or could be a faulty rave solenoid.

  7. #7
    I had an 01 that did what sounds to be the same as your problem and on mine it was in the mpem plug where the tps wires enter the mpem, inside the plug the female end had slipped back into the plug slightly and sometimes the plug would make contact reaching max revs, worth a look

  8. #8
    Quote Originally Posted by winterstick View Post
    I had an 01 that did what sounds to be the same as your problem and on mine it was in the mpem plug where the tps wires enter the mpem, inside the plug the female end had slipped back into the plug slightly and sometimes the plug would make contact reaching max revs, worth a look
    That must have been a nightmare to hunt down!

  9. #9
    i 6th raves - you should be able to check the solenoid with a low pressure gauge like 30 psi mikuni pop off tester.

    here is tps test info for those that might happen upon this thread in a search
    BTW - diagram compliments of MicroTouch
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	TPS-3.jpg 
Views:	71 
Size:	92.9 KB 
ID:	110141  

  10. #10
    Quote Originally Posted by ohell View Post
    i 6th raves - you should be able to check the solenoid with a low pressure gauge like 30 psi mikuni pop off tester.

    here is tps test info for those that might happen upon this thread in a search
    BTW - diagram compliments of MicroTouch
    Good info to have, thanks!

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Still have the same problem with my 94 SL650
    By RNusbaum in forum Polaris Open Discussion
    Replies: 9
    Last Post: 10-10-2012, 06:51 AM
  2. still having problems with 95 800 xp
    By TonyT in forum 2-Stroke Performance
    Replies: 11
    Last Post: 06-21-2010, 07:14 PM
  3. 2005 Seadoo RXT STILL having oil pressure probs...
    By kaorder1999 in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-18-2010, 09:55 PM
  4. 2005 Seadoo RXT STILL having oil pressure probs...
    By kaorder1999 in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-17-2010, 12:08 PM
  5. WTB: Performance Parts For 00 XP
    By Seadooman03 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 09-07-2008, 01:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •