Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    gms05rxt's Avatar
    Join Date
    Dec 2008
    Location
    Mount Holly, NC
    Posts
    148
    +1
    2

    possible broken washers or worse

    9 Months ago my ski had 105 hrs and the supercharger gear broke.BMS replaced the supercharger as well as the oil pumps ,stator and misc other damaged parts under warranty which expired while my ski was there in April.I got it back and it ran fine.After 2 rides the low oil warning came on and the dipstick read nothing.I took it back and they fixed an oil leak.A few rides later same deal, no oil and the low oil warning.They found the problem and fixed the leak.Now I went to ride and the ski and it wont go over 50mph and the tach wont go over 6k.This is how the ski acted when I broke the SC gear.I wonder if from going 65mph with low oil on various occasions maybe I did damage which has lead up to either the washers went or the sc went.I now have 120 hrs.I rode only 15hrs and now who knows if they are gonna fix it because it was under warranty last time and now it expired.Im gonna drop it off tomorrow.Wish me luck.


  2. #2
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    check the hose from s/c hasnt popped off and then see if you can turn the s/c with your finger through the centre of the s/c where air intake hose fits on.

  3. #3
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,548
    +1
    4,767
    Yes, and if you plan on keeping it you need to replace the ceramic OEM clutch washers immediately with metal washers. Replacing the OEM parts with more ceramic washers will not help you at all. Read more here:
    http://greenhulk.net/forums/showthread.php?t=19887

  4. #4

    Join Date
    Jul 2008
    Location
    ENGLAND
    Posts
    605
    Quote Originally Posted by gms05rxt View Post
    9 months ago my ski had 105 hrs and the supercharger gear broke.bms replaced the supercharger as well as the oil pumps ,stator and misc other damaged parts under warranty which expired while my ski was there in april.i got it back and it ran fine.after 2 rides the low oil warning came on and the dipstick read nothing.i took it back and they fixed an oil leak.a few rides later same deal, no oil and the low oil warning.they found the problem and fixed the leak.now i went to ride and the ski and it wont go over 50mph and the tach wont go over 6k.this is how the ski acted when i broke the sc gear.i wonder if from going 65mph with low oil on various occasions maybe i did damage which has lead up to either the washers went or the sc went.i now have 120 hrs.i rode only 15hrs and now who knows if they are gonna fix it because it was under warranty last time and now it expired.im gonna drop it off tomorrow.wish me luck.
    if,the work that was done was done under warranty,that work is new work and should be garunteed,so if its failed it should be considered to be defective work and put right at their expense.you can argue that they havent solved the problem and you are having the same problem as before,so they should sort it free of charge and garuntee it,12mths is the norm in the uk,even if they put it right on the last day of warranty,that work should be covered for a set time

  5. #5
    gms05rxt's Avatar
    Join Date
    Dec 2008
    Location
    Mount Holly, NC
    Posts
    148
    +1
    2
    Ok I started it for a second and squeezed the hose from the SC to the TB and no pressure was felt.I pulled the hose and put my fingers inside and the sc spun freely.Sounds like Im gonna raise hell at the dealer tomorrow.All that work and the ski lasted 15 hrs.

  6. #6

    Join Date
    Jul 2008
    Location
    ENGLAND
    Posts
    605
    Quote Originally Posted by gms05rxt View Post
    Ok I started it for a second and squeezed the hose from the SC to the TB and no pressure was felt.I pulled the hose and put my fingers inside and the sc spun freely.Sounds like Im gonna raise hell at the dealer tomorrow.All that work and the ski lasted 15 hrs.
    WHAT A F;;;KER

  7. #7
    is it making a whining sound? could be SC bearings

  8. #8
    gms05rxt's Avatar
    Join Date
    Dec 2008
    Location
    Mount Holly, NC
    Posts
    148
    +1
    2
    No whining whatsoever

  9. #9
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Who was the dealer? My guess is that it wasn't PPG... Ron

  10. #10
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,548
    +1
    4,767
    Quote Originally Posted by gms05rxt View Post
    Ok I started it for a second and squeezed the hose from the SC to the TB and no pressure was felt.I pulled the hose and put my fingers inside and the sc spun freely.Sounds like Im gonna raise hell at the dealer tomorrow.All that work and the ski lasted 15 hrs.
    Dude, listen to me.
    It's not totally your dealer's fault. It's BRP's fault as well. The OEM parts they designed and used are the problem. Like I said before, if you instruct them to keep replacing the OEM parts with more ceramic washers you are setting yourself up for failure no matter how many times they fix it. It's a vicious cycle. Some of those ceramics have failed within a couple of hours so the fact that yours failed at 15 hours is really not a surprise. You need metal washers. My dealer was very familiar with this problem, and they replaced the ceramics with Riva washers and they did it without voiding my warranty. Keep in mind, you may need to shop around to find a "mod friendly" dealer, but in the long run that is your best solution. Jerry can also help you with parts from the online store here at Green Hulk. Read more here:
    http://greenhulk.net/forums/showthread.php?t=19887

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. For better or worse?
    By ou812 in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 01-14-2012, 12:23 PM
  2. Possible parts ski or builder?
    By Piston in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 09-01-2009, 03:40 PM
  3. Replies: 0
    Last Post: 07-18-2009, 12:42 PM
  4. wtb: possible x-charger or rude 1
    By PTLanza in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-02-2009, 10:56 AM
  5. wtb broken RXT or RXP riva grate
    By GPRXPJared in forum Sea Doo Classifieds
    Replies: 10
    Last Post: 03-11-2009, 09:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •