Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3

    RXP-X Cavitation

    I got my RXP-X modified running 77-78 on GPS but hurting from cavitation out of the hole. I have bent (Trailing Edge) the 15/22 to get my RPMs to 8440 and have drilled (3/8 holes) the grate and pump shoe. I am also running the Pump Extension.
    Do you think I need a 3 blade or are the holes are causing the cavitation?


  2. #2
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Quote Originally Posted by Antiguan RXP View Post
    I got my RXP-X modified running 77-78 on GPS but hurting from cavitation out of the hole. I have bent (Trailing Edge) the 15/22 to get my RPMs to 8440 and have drilled (3/8 holes) the grate and pump shoe. I am also running the Pump Extension.
    Do you think I need a 3 blade or are the holes are causing the cavitation?
    What wear ring are you running? I was having the same issue and it was because a bailer line got caught between my Rear intake and my carbon boot, the pressure on the boot was causing it to cavitate real bad. So make sure nothing is touching your carbon boot, check your clearance on your wear ring to prop and if that's not your problem, hopefully someone else will chime in with other ideas.

  3. #3
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by Alex13 View Post
    What wear ring are you running?
    I was having the same issue and it was because a bailer line got caught between my Rear intake and my carbon boot, the pressure on the boot was causing it to cavitate real bad. So make sure nothing is touching your carbon boot, check your clearance on your wear ring to prop and if that's not your problem, hopefully someone else will chime in with other ideas.
    He has the pump extension installed so SS linear.

  4. #4
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by Antiguan RXP View Post
    I got my RXP-X modified running 77-78 on GPS but hurting from cavitation out of the hole. I have bent (Trailing Edge) the 15/22 to get my RPMs to 8440 and have drilled (3/8 holes) the grate and pump shoe. I am also running the Pump Extension.
    Do you think I need a 3 blade or are the holes are causing the cavitation?
    What nozzle are you running?
    How much did you bend your 15/22?

    I think that the 15 degrees on the prop can cause cavitation when you have alot of power. I have seen where a 13 degree on front of prop will spin much better without cavitation out of the hole.
    That does not mean that you can not run a 15/22 without cavitation. IF you have bent the traileredge alot, then your prop may not be effiecent anymore. YOu can only bend the trailering edge of prop so much either way before you screw up the progrssive pitch that is needed.

    The 3 blade has been tested on the P-X and I have not heard anything good about it.

  5. #5
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by skoepp View Post
    He has the pump extension installed so SS linear.
    True, I would be looking at the carbon seal like Alex mentioned. Also being that he just installed the pump extention I woul make sure the rubber bumper is installed on the shaft. If not it can allow the shaft to walk forward under hard ecceleration and suck air around the carbon seal.
    Have you noticed any extra water in the hull?

  6. #6
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    The hull is always dry, I used a brand new carbon/floating ring & driveshaft and it when together perfectly. The rubber bumper was installed. Out the hole hard and hit hits the limiter for about 2 seconds then pulls like a missile right up to 77.
    I am running the 83mm nozzle and took about 1.5mm out of the 15/22. I read somewhere that the 3/8 holes in the grate could cause some cavitation, any truth to this?

  7. #7
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Anyone else running the pump extension with cavitation problems?

  8. #8
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    What intake grate are you running?
    Excuse me if you have already stated this.

  9. #9
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Quote Originally Posted by skoepp View Post
    What intake grate are you running?
    Excuse me if you have already stated this.

    I am running the Riva grate.

  10. #10
    Quote Originally Posted by Antiguan RXP View Post
    I am running the Riva grate.
    Have you tried a worx or r&d? If you have one laying around? Could be carbon seal. Under heavy load out of the hole it may suck some air.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 03-08-2011, 12:56 AM
  2. RXP-X cavitation after SC mod
    By ZeXteR in forum 4-Tec Performance
    Replies: 7
    Last Post: 10-18-2010, 10:04 PM
  3. 04 RXP Bad Cavitation at start
    By jekvall in forum 4-Tec Performance
    Replies: 11
    Last Post: 04-12-2010, 07:19 PM
  4. RXP X cavitation
    By Sheepfu in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-06-2009, 12:42 PM
  5. RXP-X cavitation
    By Water Pig in forum 4-Tec Performance
    Replies: 10
    Last Post: 09-14-2008, 03:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •