Results 1 to 9 of 9
  1. #1
    I want a fast ski...Faster than that.
    Join Date
    Dec 2008
    Location
    Gonzales, La
    Posts
    101

    RXT-X only getting to 6200 rpms

    I just purchased a RXT X and it has 40 hrs on it. I am only getting to 6200 rpms. The guy i purchased the bike from says that it may be a filed spark plug from the storage oil. Does this sound right?


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by clouless View Post
    I just purchased a RXT X and it has 40 hrs on it. I am only getting to 6200 rpms. The guy i purchased the bike from says that it may be a filed spark plug from the storage oil. Does this sound right?
    Check your intercooler hoses. One may have come off, or is leaking.
    Be sure oil is not over filled, i doubt it is that but just check. Oil needs to be in middle of marks on dip stick when warm.
    Check your sc for slipage.

    It was not in storage long enough to foul a plug IMO.
    I have never had foging an engine foul the plug.

  3. #3
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Can you hear the SC whine?... Ron

  4. #4
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,581
    +1
    4,795
    It's probably shot, I'll give you $1,000 cash for it...

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Pull the intake hose off the supercharger and try to spin the impeller with your finger. If you can spin it your clutch is toast. I have seen quite a few of the oem metal washers breaking and falling off the shaft.

  6. #6
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    if it breaks and falls off the shaft is it the same situation as when the ceramics broke and fell off??
    since this ski is under warranty ( i assume) dealer needs to pull engine to properly clean parts and rebuild the SC????
    CLOULESS, check your warranty, as normal warranty runs out after 1 year and you may be getting close to that, then this should be a dealer repair, if this is your first pwc,i would strongly suggest extending the warranty thru the dealer for 4 yrs, money well spent on these 4stroke engines as any reapir can be very costly, and the warranty will pay for itself, should anything go wrong.
    ps, you can only purchase extended warranty BEFORE the original warranty runs out!!!

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by lextoy View Post
    if it breaks and falls off the shaft is it the same situation as when the ceramics broke and fell off??
    It depends.... sometimes it breaks in 2 pieces and you find it in the front oil scavenger pump screen with no other damage.

    other times it gets munched up between the timing chain and the gear damaging the chain.

    Often it will chip gear teeth on the double row gear.

  8. #8
    I want a fast ski...Faster than that.
    Join Date
    Dec 2008
    Location
    Gonzales, La
    Posts
    101
    Hey guys. Sorry I've been out of touch. I brought the ski down to Bruce Taylor Wednsday night. He was nice enough to meet me at the New Orleans Boat Show and pull it home to Chalmette (he will have all of my business from now on; great guy). He stayed up until 2 that morning and said that one of the washers broke or something to that effect. He is going to pull the motor out just to take extra precautions that no fragments got in the motor. I will have the ski back Monday so me and her can start blazing the waterways. Thanks for all of the phone support and help I got from yall on here. I've never been much into forums, but you guys had 4 answers for me while I was still on hold with the dealership. Thanks again and thanks to Bruce Taylor for going above and beyond to help me. Much appreciated!

  9. #9
    Never say never KirkF350's Avatar
    Join Date
    Jun 2005
    Location
    Midlothian, Texas
    Posts
    4,433
    +1
    3
    Quote Originally Posted by clouless View Post
    I will have the ski back Monday so me and her can start blazing the waterways.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 05-01-2016, 02:04 PM
  2. Riva stage 1 RXTX only revving to 7700 RPM
    By stevea99 in forum 4-Tec Performance
    Replies: 14
    Last Post: 11-15-2014, 11:47 PM
  3. Only getting 7650-770 rpms...Piggyback Mod???
    By Eat-My-Roost in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-01-2012, 08:51 PM
  4. Polaris SLT 780 not getting to full rpms
    By motox1027 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-26-2009, 11:00 AM
  5. HELP: only getting 7900 7950 RPM's
    By majundecid in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-16-2007, 01:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •