Results 1 to 3 of 3
  1. #1
    carbuff91's Avatar
    Join Date
    Dec 2005
    Location
    Glen Burnie, Md
    Posts
    198

    Question on Riva Sponsons install...just wondering?

    Ok,

    So, today I go and put the Riva Sponsons on my boat and I can't seem to get the black base to sit flush with the boat's hull. I'm thinking that maybe I'm putting something on wrong. I tried all kinds of way (bought used and no instructions). Finally I end up having to take the last small bolt out of the hull at the back to get the black base to fit agains that hull.

    Does this sound right? Did anyone else have to remove one bolt from each side of their ski to get the black base to fit flush. I'm just worried that now I have a bolt out on each side. Even though it looks like the base covers it when it's mounted. I may take on water.

    Anyone have instructions they can send me? Or, just say..yea, that's right or No, what the hell are you doing you freaking moron!

    Thanks everyone,
    Steve


  2. #2
    Canadian POWERHOUSE CanadianGPR's Avatar
    Join Date
    Dec 2005
    Location
    Vancouver, British Columbia
    Posts
    382
    +1
    1
    Link to instructions on Riva's site. hope this helps you out. http://www.rivayamaha.com/Instructions/ry2620_1.pdf

  3. #3
    carbuff91's Avatar
    Join Date
    Dec 2005
    Location
    Glen Burnie, Md
    Posts
    198
    I don't get why it says to remove 6 of the 10mm bolts. The base fits fine with just the one removed from each side. None the less, I guess I'll be taking it all back off and filling in the two holes with something to stop any water from getting in. Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva Sponson Install
    By T5Racing in forum 4-Tec Performance
    Replies: 1
    Last Post: 02-23-2009, 05:41 PM
  2. Riva Sponson Install Question
    By RobbieMWD in forum 4-Tec Performance
    Replies: 4
    Last Post: 11-21-2008, 05:33 AM
  3. Question on RIVA intake grate
    By MPower in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-29-2007, 01:20 PM
  4. question on 787 motor install shiming/align.!!!!!
    By flyby9er in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-18-2007, 12:50 AM
  5. Questions On Riva Grate Install
    By Flynfox in forum 4-Tec Performance
    Replies: 12
    Last Post: 03-29-2007, 11:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •