Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Feb 2007
    Location
    Chino,Calif.
    Posts
    45

    New wear ring and impeller

    I just got a new wear ring and Solas concord srx-cd-14/19 for my stage 1 '04 RXP.(second one) The stock wear ring has the updated part#. When I put the new impeller inside the wear ring(on the bench) there seems to be a lot of play. I put the same impeller in an older wear ring I had got out in one piece. It was a lot tighter. Is this normal? Phil


  2. #2

    Join Date
    Aug 2006
    Location
    Gonzales, La
    Posts
    2,145
    +1
    9
    The new wear rings have a much tighter fit in the pump, so the ID will shrink down some when its installed.

  3. #3

    Join Date
    Feb 2007
    Location
    Chino,Calif.
    Posts
    45
    I put the impeller in the new wear ring and pushed it to one side. Then I tried to stuff feeler gauges in the gap. It was over 100 thousandths. Is that to much? Phil

  4. #4
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    With the wear ring and impeller in the pump, the wear limit is .014" around the blades with would be .028" total side-to-side. I can't see how you can measure it before you put it in the pump. Did you get a Sea Doo brand wear ring? It should have a 267000105 part number, but is probably superceded by a newer part number. That's all that's listed on the online parts catalogue... Ron

  5. #5
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    Maybe you accidentally got a 155 mm wear ring as opposed to
    the 159 mm you should have.. I don't parts numbers.. Maybe
    someone can chime in if they have the 2 correct #'s.

  6. #6
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by Foggy View Post
    Maybe you accidentally got a 155 mm wear ring as opposed to
    the 159 mm you should have.. I don't parts numbers.. Maybe
    someone can chime in if they have the 2 correct #'s.
    A 159-mm impeller wouldn't fit in a 155-mm wear ring. Maybe someone swapped the metal pump in the RXP for a GTX plastic pump and that's 155-mm... Ron

  7. #7

    Join Date
    Aug 2006
    Location
    Gonzales, La
    Posts
    2,145
    +1
    9
    The new wear rings compress A LOT when installed. Put it in and then check it. It's impossible to tell otherwise.

  8. #8
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by engineermike View Post
    The new wear rings compress A LOT when installed. Put it in and then check it. It's impossible to tell otherwise.
    +1

  9. #9
    SeaGoat's Avatar
    Join Date
    Jun 2008
    Location
    Jacksonville, N.C.
    Posts
    2,214
    +1
    2
    I know my new wear ring was a total biatch to get in. Froze it too. Old one came out easy. New one, not so much.

  10. #10

    Join Date
    Aug 2006
    Location
    Gonzales, La
    Posts
    2,145
    +1
    9
    Yea they changed the dimensions of them. The old ones were easy but the new ones are a PITA. I dread the day I have to pull one of the new ones out. May have to chisel it out.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pic of new wear ring and impeller
    By travis ingram in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-13-2015, 04:04 AM
  2. New wear ring and impeller BEWARE
    By travis ingram in forum 4-Tec Performance
    Replies: 16
    Last Post: 05-11-2015, 02:13 PM
  3. wear ring and impeller seal
    By rxpsalonika in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-14-2009, 04:22 PM
  4. New wear ring and prop straightened
    By kndtenn in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 09-01-2007, 08:29 AM
  5. wear ring and impeller ????
    By BJTKRXPHD in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-22-2006, 06:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •