Results 1 to 3 of 3
  1. #1

    **Help Needed - Multi Function Display

    I have a 1995 Waveraider Deluxe (RA700AT). The PWC runs fine, but the multi function display does not show any information. There's power on the red wire to the display, but no power on the green wire. The shop manual shows power should be on both. The green wire originates at the electrical unit (EU). The fuse is good in the EU. I have the shop manual, but is there an electrical schematic for this PWC so I could trace the circuit? Should I remove and inspect hte EU? What steps should I take to troubleshoot this condition?

  2. #2
    Chapter #7 in the manual I sent u

  3. #3
    TempoGT's Avatar
    Join Date
    Apr 2008
    Montreal QC

    any luck?

    Any luck with figuring out your rectifier and lighting coil? Did you try powering up the MFD on its own?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Multi Function Display Needed!!!
    By Spikester13 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-24-2013, 02:47 PM
  2. 95 Polaris SL 750, MULTI FUNCTION DISPLAY . please help
    By 750slt in forum Polaris Open Discussion
    Replies: 8
    Last Post: 05-30-2009, 10:56 PM
  3. WTB mfd multi function display 8 pin for polaris sl 1050
    By boatinj in forum Polaris Classifieds
    Replies: 26
    Last Post: 01-01-2009, 07:43 PM
  4. 95 vs 96 multi function display
    By 95yami701 in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 07-21-2008, 06:44 PM
  5. 1996 SLT780 Multi-Function Display Woes
    By Juiceman99350 in forum Polaris How To & FAQs
    Replies: 12
    Last Post: 08-06-2007, 08:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts