Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3

    2003 GTX Supercharger

    have a 2003 GTX supercharger 185 horsepower. Nice ski by the way. We had issues getting the ski to start. It ended up being the TOPS system, so I swapped them out. But before the swap. the entire ski went dead on us. No beep when we installed the key. Took it to the dealer, they say they can't figure out the problem either, but they did clear the TOPS code for us, but the dash does not work. They can get the motor to turn over, but dash still does not work. Anyway to test the dash or anybody have a similar symptom with the dash not working?
    Thanks,
    SHOOTER


  2. #2
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    nobody?

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Larry, unfortunately you are going to have to replace the dash.

  4. #4
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    talk to "big daddy" hes been posting up the last few days on here about his 2002 and 2003 skis, he has an extra gauge he doesnt need

  5. #5
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    Jerry, are the dashes known to just go bad on these things? I mean one second it was working, then we lost everything. No power no nothing. All we were doing was messing with the TOPS. They say now they can get the two beeps, motor to turn over, but dash does not work.
    Well a dash out of an 05 gtx work on an 03?
    Also, Lextoy who is big daddy, if I had to guess I'd say you were talking about Jerry, hahaha.
    SHOOTER

  6. #6
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Have you checked the obvious things like battery condition, corrosion inside connectors, fuses and stuff like that? I would do some checking before I bought a new cluster... Ron

  7. #7
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,062
    +1
    790
    Quote Originally Posted by King_Of_Fun View Post
    Have you checked the obvious things like battery condition, corrosion inside connectors, fuses and stuff like that? I would do some checking before I bought a new cluster... Ron
    Shooter, i am sure you did this, but just checking also. Grounds fuses and corrosion?

    .

  8. #8
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    Ski is mint condition. Odyssey dry cell battery. All connections good to go as far as ground, even checked the positive. We looked at all the fuses on the side panel. Are there more fuses on the ski besides the one on the mpem?
    SHOOTER

  9. #9
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14

  10. #10
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Here are a couple pages from the Owners Manual and Service Manual with things to check. The 1-amp fuse in the left and test procedure for the Info Center... Ron
    Attached Files Attached Files

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 GTX Supercharged Question - Cavitation or Rev Limiter?
    By ccstamoulis in forum 4-Tec Performance
    Replies: 45
    Last Post: 06-22-2011, 06:39 PM
  2. WTB WTB 4 TEC Engine or core For 2003 GTX Supercharged 185 horse
    By xprider02 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 02-22-2011, 09:03 PM
  3. 2003 gtx supercharger 4-tec slips when pulling out of water.
    By motormadness in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-10-2010, 09:16 PM
  4. 2003 GTX supercharged, should I do it?
    By HiPeRcO in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 07-25-2007, 08:46 AM
  5. 2003 GTX Supercharged wear ring problems
    By Zilla57 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-10-2006, 12:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •