Page 1 of 16 12311 ... LastLast
Results 1 to 10 of 157
  1. #1

    Join Date
    May 2005
    Location
    Cotton Country
    Posts
    62

    Lost supercharger clutch this weekend

    Well I lost the supercharger clutch on my rxt this weekend @ 24.7hrs. on the clock. Just so happen's that it only ran 4.7hrs after the sea doo dealer changed my oil! I spoke with the mechanic about not useing synthetic oil and I looked at the bottle's when he got threw and it was the 10w-40 4TEC seadoo stuff he put in. So I dont think it was oil related. I took the intake tube off and could spin the impeller with my finger. Man this stinks. I thought the 05's had better s/c clutching.

    It ran strong last weekend,when I put it up it was running fine. Didnt last but 15 min before RPM's dropped to 6450. I knew right off what it was and was PO'd...... Day over.....was all gassed up,cooler loaded and everything.


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,980
    +1
    1,898
    man that sucks! sorry to hear!

  3. #3
    1969camaro-rs's Avatar
    Join Date
    Jul 2005
    Location
    knoxville,tenn
    Posts
    21
    im new to this so try not to laugh at me to hard .....lol...but i was also riding my 05 rxp today and all of a sudden it has lost power .....wide open its going about 52 and rpm is only capable of 6300....its just turned 18 hrs ...have i lost a s/c clutch or something ????im kinda lost but the way im reading the forums it seems i might have broke it or something .....is there any way i can tell????........is this something i have done ????any help or advise you can give me would be appreciated ....thanks

  4. #4

    Join Date
    May 2005
    Location
    Cotton Country
    Posts
    62
    Can you hear the supercharger whine? If not its toast just like mine.

  5. #5

    Join Date
    Apr 2005
    Location
    Augusta GA
    Posts
    720
    camaro-rs
    yea it sound like you lost you SC also. That seam to be a common sound when the SC cluch goes out.

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,980
    +1
    1,898
    RS Camaro, you did nothing wrong. Unfortunately the clutch on your supercharger went out. Take it to the dealer!

  7. #7

    Join Date
    May 2005
    Location
    Cotton Country
    Posts
    62
    Why would the supercharger go out so quick? I havent beaten on it much at all and I let off the gas when the ski comes "unhooked" in the water. I did run it hard wide open for 20 min or so trying to get back to the cabin.

  8. #8
    BertInTexas's Avatar
    Join Date
    May 2005
    Location
    Central Texas
    Posts
    377
    I cringe every time I read about another clutch failure.Dammit SeaDoo needs to step up to the plate and do a recall or something here.My warranty is long gone and it seems my clutch will eventually fail like so many others have and when it does.........I'm gonna be pissed!

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,980
    +1
    1,898
    The clutch is a wear item so it enevitable that it will fail one day.

  10. #10

    Join Date
    May 2005
    Location
    Cotton Country
    Posts
    62
    Yea im pissed right now,I thought the 05's had an updated clutch?

Page 1 of 16 12311 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lost my rear fzr seat this weekend.
    By Doug78 in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 08-29-2010, 08:00 PM
  2. Additional Shim for Supercharger Clutch
    By johnD in forum 4-Tec Performance
    Replies: 14
    Last Post: 07-24-2009, 09:55 PM
  3. Thought I blew up the clutch this weekend
    By Lurker in forum 4-Tec Performance
    Replies: 4
    Last Post: 10-26-2005, 11:42 PM
  4. Changing oil this weekend does it have to be for wet clutch
    By macattack in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-17-2005, 10:03 PM
  5. Got my rxp to 79 this weekend!
    By MikeTrin in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-10-2005, 03:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •