Results 1 to 10 of 10
  1. #1

    Join Date
    Aug 2008
    Location
    nverness, FL
    Posts
    95

    throttle sticks after running it for awhile

    when it warms up the the throttle sticks.. what up wth that?? its a 2000 gp1200r


  2. #2
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Answer is right here in the "How to" section http://www.greenhulk.net/forums/showthread.php?t=69452

  3. #3

    Join Date
    Aug 2008
    Location
    nverness, FL
    Posts
    95
    good deal thanks

  4. #4
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Your welcome

  5. #5
    i will get all the rest i need when im dead corkycat's Avatar
    Join Date
    Jan 2009
    Location
    uk
    Posts
    840
    +1
    1

    hm

    i had the same prob on my 1200 just greased up and wd40,d did the trick

  6. #6
    jarrod_bridges2000
    Guest
    Im waiting for mine to do that so it will be stuck wide open and it will give my finger a break

  7. #7
    i will get all the rest i need when im dead corkycat's Avatar
    Join Date
    Jan 2009
    Location
    uk
    Posts
    840
    +1
    1

    hm

    well thats easy just tape your throttle to your bars so its wide open voila no more finger ache

  8. #8
    noshowallgo's Avatar
    Join Date
    Mar 2007
    Location
    GA
    Posts
    133
    +1
    1

    Talking

    Quote Originally Posted by jarrod_bridges2000 View Post
    Im waiting for mine to do that so it will be stuck wide open and it will give my finger a break
    right on>

  9. #9
    noshowallgo's Avatar
    Join Date
    Mar 2007
    Location
    GA
    Posts
    133
    +1
    1
    Quote Originally Posted by corkycat View Post
    i had the same prob on my 1200 just greased up and wd40,d did the trick
    can you contact me directly and tell me what you greased and wd40? where?

  10. #10
    jarrod_bridges2000
    Guest
    Quote Originally Posted by noshowallgo View Post
    can you contact me directly and tell me what you greased and wd40? where?
    take off seat cover, at the very front of the engine, stick your head down there ( please dont start it ) and pull the throttle and you will see a little wheel move and thats the throttle cable. Spray that entire setup with wd-40 along with the cable then pull the throttle all the way and you will see the cable when you pull the throttle all the way back right behind the throttle lever spray that with wd-40 also and your good to go!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 polaris sl 750 dies after running it all out for a 5-10 minutes
    By abbieg250 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-02-2012, 11:11 PM
  2. It runs great, for awhile
    By tax man in forum MSX/Matrix
    Replies: 9
    Last Post: 06-14-2012, 10:20 AM
  3. Replies: 18
    Last Post: 11-05-2011, 04:42 PM
  4. Throttle Sticking Only when engine is running
    By linuxglobal in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 04-17-2009, 08:33 AM
  5. virage won't start after running for a while
    By culby-wan-kanobi in forum Polaris PWC Performance
    Replies: 27
    Last Post: 08-07-2008, 02:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •