Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366

    Update On My GTX...

    I have the engine in, changed the impeller to the one off the supercharged ski, cause the stock motor was not supercharged and the impeller was different.

    That solved the problem of 50mph @ 8000rpm
    Now I get 55.5 mph at ~7500~ rpm, I guess the high hrs are showing cause i cant go any faster than 55.5 (gps) And it was rather cold today, so when it warms up ill be slower. I want to go faster than this guy in his bass boat, lol.

    What would be some power losses on this ski? is something wore out?
    I just put a new wear ring along with the right impeller so its not that.

    Also i wanted to ask, what would be some issues of me running a filter like this one put directly onto the SC? would CHK ENG light come on?


    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	KN_Cobalt_CAI.jpg 
Views:	45 
Size:	79.9 KB 
ID:	112852  


  2. #2
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    you gotta read up on the air intake modifications for the 4tec.
    that is like what we use onthe seadoo's, however you DO NOT want to stick it directly onto the SC, you want to get some elbows and clamps that get it drawing fresh air from under the rear seat, or drawing fresh air from up under the steering column.
    first you need to solve your speed problem, you need to pin the flippers up for now to make sure they are not dragging in the water. my bet is they are stuck in the down position.
    plus excessive corrosion on the rideplate intake grate could slow you down.

  3. #3
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366
    there is no corrosin on the machine at all thats y i chose to put the engine in it. And sorry Im still a noob to these things, what are the flippers? the things on the side that help steer?

  4. #4
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    Do you have a 215 engine in it now?

  5. #5
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Cut 2 pieces of 3/4" PVC 2" long. Cut a 1/4" slot lenghtwise in each piece. Hold the the OPAS fin up and snap on the PVC on the OPAS shaft; do each side... Ron

  6. #6
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366
    Quote Originally Posted by GOLD06RXP View Post
    Do you have a 215 engine in it now?
    no, I do belive its a 185 supercharged, I would like to get mor hp but the other superchargers are very expensive.
    What would it take to go 60-65?

  7. #7
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Riva stage 1 kit advertises 66 - 67 mph and consists of:
    1. 3" intake (that most make with 4" flex tubing)
    2. OPAS competition Kit - PVC pieces from above
    3. Riva Toploader grate
    4. new impeller (Solas CD-13/20R)
    5. 2 degree wedge
    Niw, I'm pretty sure you can find a used impeller and grate. You may already have the wedge. You might get these for maybe $200 - $300.

    Don't forget about filling the rideplate & grate holes which can be good for up to 1 mph.

    Checkout Rivas claims:

    http://www.rivayamaha.com/pwc_perf_p...c_stg1_kit.asp

    Then, maybe a Fizzle IC kit... Ron

  8. #8
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    your ski in stock form should be gettting 61-63 mph. approx 7500-7650 rpm.
    something else is still wrong. how were the pump vanes inside the venturi, when you changed out the impeller?
    possibly your stock impeller is way out of whack, they have been known to be off pitch pretty badly. best option is to upgrade to a solas 12/20, if you do a little bit of modding you can get it to run strong with this impeller.
    are you cavitiating? outof the hole, or thru the powerband? if it is it could be robbing you of speed. you need ot check the carbon ring/seal on teh driveshaft inside the hull. if it is out of round, or worn unevenly, or if the accordion boot is not keeping adeqaute pressure against it it could be leaking air into the pump cavity, thus cavitation. it could also leak water into your hull, and you could sink... so make sure its not weak!

  9. #9
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    make your own 4 " intake.
    get about 7 feet of kanaflex hose.
    get a 4" SS airfilter form spectre performance they are on sale on amazon real cheep!!
    get a 3"--> 4" silicone reducer 90* elbow from www.siliconeintakes.com
    get some 4" couplers to clamp this all to gether with.
    then install in your ski run
    90* elbow onto the SC
    metal coupler
    7' of kanaflex hose
    metal coupler
    SS airfilter
    put the airfilter up on top of the fuel tank near where the air hole is abov eyour glove box. remove all the tubing that is curently coming form the hole above the airbox. and of cours eyou will need to remove all teh stock plastic airbox and tubes that run from the mushroom lookin air intake all the way to the SC.

  10. #10
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    if you are thinkin of doing this let us know, we have all done it, and know all the parts and what needs to go where
    theres a heat sink you need to put somewhere and a crancase vent you need to put somewhere. both are easy to deal with...

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Update On My GTX, Vol 2. Things working out.
    By xBigDaddyx117 in forum 4-Tec Performance
    Replies: 8
    Last Post: 02-21-2009, 08:42 PM
  2. Updat on my BAD luck..YES
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 02-23-2006, 11:14 PM
  3. Update on my paperwork problem with the Ski
    By Pettee in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 01-19-2006, 04:36 PM
  4. Pics of Nils/Mark Thru Hull Exhaust on my GTX S/C LTD
    By Red Devil in forum 4-Tec Performance
    Replies: 26
    Last Post: 12-20-2005, 05:00 AM
  5. Hulk's pitch on my GTX
    By Red Devil in forum 4-Tec Performance
    Replies: 18
    Last Post: 10-31-2005, 11:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •