Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    hayabusarider's Avatar
    Join Date
    Oct 2008
    Location
    DFW, Texas
    Posts
    52

    What RPM should H20 flow with stinger mod?

    I need to verify the jetflow valve is working correctly. What RPM should water start flowing into the modded Stinger? 3000 RPM?
    Thanks.


  2. #2
    jonny5's Avatar
    Join Date
    Aug 2005
    Location
    Redding, CA
    Posts
    1,266
    +1
    5
    3000 rpm is about right and what everyone else seems to run.

    Did you just install this...?? Did you do a before and after test.

  3. #3
    hayabusarider's Avatar
    Join Date
    Oct 2008
    Location
    DFW, Texas
    Posts
    52
    Quote Originally Posted by jonny5 View Post
    3000 rpm is about right and what everyone else seems to run.

    Did you just install this...?? Did you do a before and after test.
    Thanks for the reply. I just installled this. I tried to verify the flow valve function while the Ultra was in the water on the trailer. I throttled up to 3000-4000 rpm with the hose off at the stinger. No indication of flow.
    I rode the ski for an hour to hour and a half. The stinger never got beyond warn to the touch. Checked for a blockage and all is good.
    Please give me some feedback and elaborate on the "before and after test"
    Ron

  4. #4
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Sounds like it probably is comming on at some higher rpm but 3k is where it should be. No water will get you a burned coupling.

  5. #5
    jonny5's Avatar
    Join Date
    Aug 2005
    Location
    Redding, CA
    Posts
    1,266
    +1
    5
    Since it didnt burn down I assume it's flowing some water....like he said maybe around 5000....

    It's not backward I assume....

    What kind of jetworks the one ya twist or the one you add washers to??

    Did you happen to notice any differance in the way the ski ran. Like better bottom.....or mid or top or worse anywhere or did it seem the same???

  6. #6
    hayabusarider's Avatar
    Join Date
    Oct 2008
    Location
    DFW, Texas
    Posts
    52
    Quote Originally Posted by jonny5 View Post
    Since it didnt burn down I assume it's flowing some water....like he said maybe around 5000....

    It's not backward I assume....

    What kind of jetworks the one ya twist or the one you add washers to??

    Did you happen to notice any differance in the way the ski ran. Like better bottom.....or mid or top or worse anywhere or did it seem the same???
    Yes, it is installed with the arrow towards the stinger fitting. It is a twist type. The Ski runs faster and jumps harder off the line. I ran an indicated top speed of 76 mph. Hoping to see real 66-67mph? Going out again today to GPS it.
    Thanks Ron
    Last edited by hayabusarider; 01-23-2009 at 09:16 AM. Reason: added comment

  7. #7
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Ok its after dark where's the #s Your rpm does sound low but as you already know that may just be the tach.

  8. #8
    hayabusarider's Avatar
    Join Date
    Oct 2008
    Location
    DFW, Texas
    Posts
    52
    Quote Originally Posted by btldigger View Post
    Ok its after dark where's the #s Your rpm does sound low but as you already know that may just be the tach.
    GPS showed 66.9 mph. Rode 3 hours today and stinger never got beyond warm to the touch. It was 80 degrees and the lake was like glass.
    I think it would have been a bit faster with a small amount of chop on the lake.
    Ron

  9. #9
    jonny5's Avatar
    Join Date
    Aug 2005
    Location
    Redding, CA
    Posts
    1,266
    +1
    5
    So is this the best numbers yet or pretty close. Average...??

    So the stinger didnt get very warm huh.....did you play with it to see where it was opening

  10. #10
    hayabusarider's Avatar
    Join Date
    Oct 2008
    Location
    DFW, Texas
    Posts
    52
    66.9 mph was the best I recorded on a two way pass. I did mess with the
    flow valve. Any suggestion on how to set it up?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT-X what should it run with these mods
    By QWKRN U in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-08-2009, 08:57 AM
  2. What speed should i see with these mods
    By BAYOU FZR in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-26-2009, 04:05 PM
  3. What impeller should I use with my rxp setup
    By Mxridda02 in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-11-2009, 09:22 AM
  4. what rpms should i be turning?
    By ebarfool in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-19-2007, 01:52 PM
  5. 2000 ME sea doo gtx, what rpm should it be running
    By bamafutbal in forum 2-Stroke Performance
    Replies: 9
    Last Post: 05-11-2007, 08:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •