Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1

    Join Date
    May 2007
    Location
    Hertfordshire, England
    Posts
    82

    So... I had the ski out for the first time today...

    My god is it quick... 64.5mph on the clock..! Flat calm lake. The only thing is that it seemed to cavitate quite a bit when I was tail standing and attempting to jump it around a bit. Any ideas..?

    It picks up a treat when trimmed on the flat but gives away when turning hard and such like...


  2. #2
    2000 pro 785 (son's) 1998 pro 785 (dads) old guy in mich's Avatar
    Join Date
    Aug 2007
    Location
    sw lower mich
    Posts
    350
    stock sponsons?
    slipping, porpoising, or digging on turns?
    on 785's aftermarket sponsons help tremendiously.
    where did ya go? and how cold was it? weve been close to 0 degrees farenhight (?) for some time no open water since early december.

  3. #3

    Join Date
    May 2007
    Location
    Hertfordshire, England
    Posts
    82
    Stock sponsons and and digging in... That is normal though is is not?

    It was when I was attempting Tail Stands on her she seemed to slip a lot. I would of though it would of launched me out of the water..?

  4. #4
    Race, wreck, repeat delagem's Avatar
    Join Date
    Aug 2006
    Location
    Homer, NY
    Posts
    722
    +1
    1
    "A winddriven rain. High 46F. Winds S at 25 to 35 mph. Chance of rain 80%"

    At least that's the forecast high for London, at the airport. I can't find Hertfordshire on any map? But your postcode comes up as "Stevenage", about 30 mi north of London.....

  5. #5
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,453
    +1
    20
    Hell Gordie you're hardcore.
    Launch from a tail stand? It weighes 550lbs dry. I assume it feels lighter when under power. Was the intake grate completely submerged? I guess under those conditions,the only thing I can think of is making sure your impeller is as good as it can be,make sure the clearance to the wear ring is a tight as possible,Make sure all the pump/intake areas are sealed-no air entering the pump.Maybe a lower pitch impeller with as tight of a clearance as possible to eliminate any cavitation if this is going to be your normal riding style.You would loose top speed with a lower pitch impeller.

    64.5 mph ,was that gps? Polaris speedometers varry greatly,some times pretty close,most times very wrong.The MFD mph display are for amusement purposes only.
    What were your RPM"s? I'm not sure if Polaris has a recommended rpm in 2000,but it should be 65-6700 rpm????.I hope somebody with a 1200 chimes in.

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,268
    +1
    23
    3 quick questions.

    Which impeller is in it?

    And what is the impeller to wear ring clearance?

    Where was your trim set at?

  7. #7

    Join Date
    May 2007
    Location
    Hertfordshire, England
    Posts
    82
    Morning guys... I am not sure of the impeller or the clearance. Going to have a look today buy after my ride yesterday I had a quick look through the pump and could see past the blades of the impeller. I thought the blades always overlapped..?

    xlint89 - I was trimmed right up on the nozzle to get the nose right up and making it easier to tail stand. Don't get me wrong it did go up but I would of though it would of been able to launch itself and me out of the water... I could be wrong like...

  8. #8

    Join Date
    May 2007
    Location
    Hertfordshire, England
    Posts
    82
    Casey67 - The grate was submerged and was on the clock of the ski (MFD). She was flying like and when trimmed up good, it was loads of fun. Normal riding the hookup seemed fine but when I wanted to chuck it about a bit, the hookup was not so good and frlt as though it was just spinning up the pump...

  9. #9
    2000 pro 785 (son's) 1998 pro 785 (dads) old guy in mich's Avatar
    Join Date
    Aug 2007
    Location
    sw lower mich
    Posts
    350
    Quote Originally Posted by GeordieBoyKel View Post
    Stock sponsons and and digging in... That is normal though is is not?

    It was when I was attempting Tail Stands on her she seemed to slip a lot. I would of though it would of launched me out of the water..?
    sounds like its optimized for straight line speed, may want to look at dif impeller/or grate/plate combo. sorry dont know ins and out of 1200's, but im sure someone does here. good luck and cheers!

  10. #10
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,268
    +1
    23
    Quote Originally Posted by GeordieBoyKel View Post
    Morning guys... I am not sure of the impeller or the clearance. Going to have a look today buy after my ride yesterday I had a quick look through the pump and could see past the blades of the impeller. I thought the blades always overlapped..?

    xlint89 - I was trimmed right up on the nozzle to get the nose right up and making it easier to tail stand. Don't get me wrong it did go up but I would of though it would of been able to launch itself and me out of the water... I could be wrong like...
    According to your description, it sounds like it may be a top speed impeller. A swirl impeller with blade overlap would definately give you better acceleration for the type of play you were doing.

    Find out what you got and how tight the clearance is. We can better guide you from there. Although it already seems like you know quite a bit already....

    When trimmed all the way up, was the water jet just shooting up out of the water? With no thrust you'll have no launch.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Took my ski out for its first test ride. :)
    By Fosta in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-23-2015, 12:51 PM
  2. Changed my oil for the first time today, god was it hard!
    By rxt260_IS in forum Sea Doo Open Discussion
    Replies: 31
    Last Post: 04-04-2013, 10:35 PM
  3. Replies: 8
    Last Post: 05-24-2011, 08:02 PM
  4. Took the ski out for the first time today..some questions
    By K-Dubb in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 03-21-2011, 11:31 AM
  5. took the new rxp out for the first time today
    By mxl16 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-17-2005, 08:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •