Results 1 to 3 of 3
  1. #1
    bruddahdave's Avatar
    Join Date
    Feb 2008
    Location
    honolulu,hawaii
    Posts
    56

    genesis i emm question

    the male prongs on my emm are bad on my genesis i. is there a way to change just the 40 prong male connector in the emm. thanks


  2. #2
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    No ,not on your own .

    You have PM

    Bernie

  3. #3
    bruddahdave's Avatar
    Join Date
    Feb 2008
    Location
    honolulu,hawaii
    Posts
    56
    thanks for the help bernie AGAIN!!!!!!! let you know how it go's

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris Genesis I oil question
    By 440/650 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-13-2011, 08:07 PM
  2. 2001 Genesis i - EMM computer mounting
    By malteseowner in forum Polaris How To & FAQs
    Replies: 11
    Last Post: 06-30-2011, 11:32 AM
  3. 1999 Genesis Ficht EMM missing can it be changed to a 2000 EMM?
    By WaveChaser in forum Polaris Open Discussion
    Replies: 16
    Last Post: 02-13-2011, 02:15 AM
  4. 2004 polaris genesis i emm
    By cmherrera in forum Polaris Projects
    Replies: 4
    Last Post: 12-30-2010, 10:30 PM
  5. 2002 genesis NO SPARK QUESTION FLYWHEEL MAGNETS?
    By greg.p in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-25-2010, 10:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •