Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    2000 xp clicks but wont turn over

    when i put the key on i get 2 beeps like normal then when i hit the start i get either click no turn over or click click click..... like the seloniod is not getting enough juice and then a long beep or i get a long beep. my battery is good and fully charged.
    Thanks


  2. #2
    PEST!'s Avatar
    Join Date
    Jun 2008
    Location
    Rockledge Florida
    Posts
    768
    ground or battery lead is corroded or even the ground cable

  3. #3
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Or...the solenoid itself is bad.

    You can troubleshoot real easy with a volt meter.

  4. #4
    well my seloniod has 12 volts going to it i checked that even shorted it out and just get a click it almost sounds like the starter starts to go but is stuck. could this be my abendix stuck/mangled or my motor is locked up? i havent ran it in about 4 months?

  5. #5
    Pull the plugs and try to turn the motor over by hand if you even think it may be locked up. I have had batteries that read 12v that are bad and won't turn the motor over. Needless to say that drove me nuts changing out the starter and solenoid to find out it was the battery. Not sure why, but changing the battery fixed the problem.

  6. #6
    DId you pull the plugs out and try to turn it over? You should also get 12V on the starter side of the solenoid when you push the start button.

  7. #7
    yes i checked and had 12 at the seloniod and at the starter. pulled the plugs and tryied but nothing just a slight jolt in the motor that acts like it wants to trun over. what / where is a good place to get a pipe wrench or something on the shaft to see if itsd locked up/ maybe free my starter abendex to see if thats it?

  8. #8
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    879
    +1
    11
    Quote Originally Posted by lostinilm View Post
    yes i checked and had 12 at the seloniod and at the starter. pulled the plugs and tryied but nothing just a slight jolt in the motor that acts like it wants to trun over. what / where is a good place to get a pipe wrench or something on the shaft to see if itsd locked up/ maybe free my starter abendex to see if thats it?
    Remove the Flywhel shroud at the rear and rotate the shaft back and forth to see if it frees up. If no joy pull the starter out and test on the bench.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	5651C7.gif 
Views:	150 
Size:	30.8 KB 
ID:	115855  

  9. #9
    I would just grab the driveshaft in the back and turn it with the plugs out. If its not locked up, you should be able to turn it over by twisting the driveshaft collar. Or you can pull the pump and do it that way.

    Actually, what surf said may be easier than pulling the pump. But sometimes that shroud doesn't want to come off because you can't get at the 10mm bolts on the bottom that screw into the stainless bracket #54 in his photo.

  10. #10
    sorry guys maybe im missing something but i dont have a cover around my driveshaft like my older xp i have a boot over my drive shaft in the back and some kind of housing that turns without turning my driveshaft. i tried to push the boot back but the housing is still there i can only see about 1/4 of an inch of my driveshaft and cant get anything on it at that point . i tried to stick my hand and turn it where it runs through my gas tank but it feels alot bigger there and couldnt really turn it there look like i will have to pull my pump. i took off the nuts that hold it on and took off the steering/trim when i tried to pull and the silicon was holding it there so i quit. should i try and cut the silicon before trying to pull it off? what should i put it back on with?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 RXP beeps, fuel pump engages, but wont turn over
    By joggernot in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-30-2015, 09:44 AM
  2. Gp1200r everything checks good, but wont turn over
    By CDW78 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 05-31-2014, 05:08 PM
  3. Seadoo XP '96 - wont turn over after 4-5 starts
    By Lurch in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 11-09-2012, 02:22 PM
  4. 96 xp wont turn over, high compression
    By snoopy'sbitch in forum 2-Stroke Performance
    Replies: 28
    Last Post: 06-17-2010, 09:35 PM
  5. 94 XP 657 engine won’t turn over
    By ade-r1 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 02-23-2010, 02:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •