Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    Jerry, Jerry, Jerry jerryspringer's Avatar
    Join Date
    Oct 2008
    Posts
    249
    +1
    8

    ski doesnt start

    hey guys,

    recently when trying to start my ski (05 rxp) i plug the lanyard in, press the start button and all i get is a clicking sound (like a solenoid or something clicking, engine doesnt turn over etc). i then remove the lanyard and after 2 0r 3 attempts, the ski will start..

    any ideas, obviously something is starting to fail, no error codes come up on gauges.. i wanna address fault b4 it gets worse and it lets me down whiltst im out on the water..

    thnaks

    Jerry,Jerry,Jerry


  2. #2
    vxrpete8's Avatar
    Join Date
    Sep 2005
    Location
    Tarpon Springs FL
    Posts
    1,048
    Need a battery possibly.

  3. #3
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Quote Originally Posted by jerryspringer View Post
    hey guys,

    recently when trying to start my ski (05 rxp) i plug the lanyard in, press the start button and all i get is a clicking sound (like a solenoid or something clicking, engine doesnt turn over etc). i then remove the lanyard and after 2 0r 3 attempts, the ski will start..

    any ideas, obviously something is starting to fail, no error codes come up on gauges.. i wanna address fault b4 it gets worse and it lets me down whiltst im out on the water..

    thnaks

    Jerry,Jerry,Jerry
    Change out solenoid, that's the problem, I'm 99% sure. Mine did the same thing. Seadoos are notorious for this, we always carry and extra when we take jet ski trip. Located on bracket up front with fuse panel, about $40 can change in easily.

  4. #4
    steved's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    358
    +1
    14
    Quote Originally Posted by Pirates81 View Post
    Change out solenoid, that's the problem, I'm 99% sure. Mine did the same thing. Seadoos are notorious for this, we always carry and extra when we take jet ski trip. Located on bracket up front with fuse panel, about $40 can change in easily.
    Yep same deal here i have now fitted 3 to my 2005 RXP

  5. #5
    yup, its the solenoid.

    Mine did the same thing, got progressively worse.

    I think the part was $50, took 15 mins to change.

  6. #6
    Jerry, Jerry, Jerry jerryspringer's Avatar
    Join Date
    Oct 2008
    Posts
    249
    +1
    8
    thanx , anyone know the part no or exactly which solenoid so i can order through online store..

    thanx

    Jerry,Jerry,Jerry

  7. #7
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Just use the Online Parts Finder (just below the Online Store) and add the solenoid to the shopping cart... Ron

  8. #8

    Join Date
    Jan 2006
    Location
    perth australia
    Posts
    124

    05 rxp wont start

    is this solenoid also called starter relay mine has just gone i think ski just clicks and battery is good, instrument panel flashes "key" its part 20 on the oem parts finder on electrical harness, cant find any part called solenoid

  9. #9
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Quote Originally Posted by tris View Post
    is this solenoid also called starter relay mine has just gone i think ski just clicks and battery is good, instrument panel flashes "key" its part 20 on the oem parts finder on electrical harness, cant find any part called solenoid
    If you display says "Key" your Dees key is not recognized.

  10. #10
    outboard john's Avatar
    Join Date
    Jun 2006
    Location
    Escondido, Ca.
    Posts
    474
    +1
    2
    Jerry, is this the original battery? I would think it's more likely that our four year old battery needs replaceing than the solenoid has mysteriously gone bad over the winter. I tried to start my ski(05 stg III RXP) the other day after having the battery on a trickle charger for a day (green light came on the charger indicating that the battery was fully charged) and the engine would turn over for a second and then just click the solenoid. Original battery showing fully charged on my charger but only reads 12.1 volts on a seperate meter(battery is toast). Swaped the original battery for my battery for my stereo(same as stock) and crank, crank, crank. Pulled the plugs, and put a little fuel in the spark plug holes, and it fired right up. I would suspect a battery problem at this point. Jump to another battery(vehicle not running) and see if your ski will crank. Good luck!
    OBJ

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 rxp start up rpms HIGH and ski doesnt move
    By wavehummer in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-05-2008, 12:14 PM
  2. trouble starting turns over yet doesnt start
    By MONKEY in forum 4-Tec Performance
    Replies: 18
    Last Post: 01-05-2008, 07:02 PM
  3. 97 xp CLUNKS ONCE N DOESNT START
    By Stoffa17 in forum 2-Stroke Performance
    Replies: 28
    Last Post: 08-14-2007, 09:00 AM
  4. Clicking noise at fuse box and ski wonts start at times.
    By excess in forum 4-Tec Performance
    Replies: 8
    Last Post: 01-08-2007, 09:45 PM
  5. Ski wont start--RXP
    By wakeborder556 in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-30-2006, 07:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •