Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    I Need Help Diagnosing A Problem..

    I have a 99' GSX RFI. Took it out today and it ran great up until the trip to the dock. I jumped a wave and when I came down it ran fine for a few seconds but then began losing RPMs. I squeezed on the throttle a little more to no avail. It never died and the engine seemed to be running fine but even holding the throttle wide open the engine stayed around 2800-3300 RPMs and didn't exceed 10 mph. I checked the plugs, made sure there was no blockage, etc. It starts up and idles just fine, it just bogs down after the throttle is depressed. Any suggestions would be great.


  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    99's should have had the beefier inductive pickup. Were you casing (slamming) waves pretty hard when it failed?

    I'm not a RFI man, but the pickup can break under hard landings.

    Welcome to the board. Hopefully a RFI man will help out too.

  3. #3
    Yes, thats exactly what happened. I slammed down on the water pretty hard. I've never worked on any of the fuel system before, from what I remember reading on the forum the pickup isn't that difficult a fix. Do you think I could pull that off myself? Thanks for the kind words. I've been a long time lurker, never had any real problems, just like to absorb the knowledge on the forum.

  4. #4
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Yes, you can do it. Chock the front of the engine with a short piece of 2x4. Then take off all the 10mm bolts on the front cover and the top bolt on the engine mount flange. Pry the cover loose in the two screwdriver slots close to the alignment pins. Only one ear is probably cracked, since it still runs. It could also be metal shavings on the solder connections on the back, or on the pickup tip.

    Good luck!

  5. #5
    Would you happen to have any pictures or descriptions of the "cracked ear" you are talking about on the pick up?

  6. #6
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    No, sorry. You will easily be able to see it once you get the cover off. It's just the metal mounting bracket that holds the inductive pickup. Just apply pressure on it and the crack/break will be exposed. It will be on the 90 degree bend close to the socket-head bolts.

  7. #7

    rfi pickup[

    in rfi the pickup is over the generetor cover not in, only remove 10mm bolt and pull out

  8. #8
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by Edgar800sd View Post
    in rfi the pickup is over the generetor cover not in, only remove 10mm bolt and pull out
    Cool! Thanks man!

  9. #9
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    RFI's dont use the same ignition system as a carbed 800. No ignition pickup like a carbed model.

  10. #10
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by water worx View Post
    RFI's dont use the same ignition system as a carbed 800. No ignition pickup like a carbed model.
    So is Edgar right or does he need other instructions?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gp1200r has no power, need help diagnosing the problem
    By kyle5647 in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-05-2013, 11:11 PM
  2. Need help diagnosing problem
    By grober02 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 08-01-2011, 06:43 PM
  3. Need Help diagnosing problem
    By Sirhc7897 in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-25-2008, 09:47 AM
  4. New and need help diagnosing my '08 rxtx
    By dr_hunt in forum 4-Tec Performance
    Replies: 50
    Last Post: 06-28-2008, 06:16 AM
  5. Need help with bucking problem
    By jgustman in forum Yamaha PWC Performance (2-stroke)
    Replies: 22
    Last Post: 01-09-2007, 05:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •