Results 1 to 6 of 6
  1. #1

    Join Date
    Apr 2008
    Location
    Lock Haven, PA
    Posts
    64

    Ultra 150 Battery not charging/battery light flashing

    Got a friend who has a 2000 Ultra 150. A new battery lasts for a week or two then goes dead. Figured it must be not charging while running because I put a battery kill on it for when he's not running it. The battery light also flashes while the ski is running, even with a brand new battery. I was told that this is the stator that is causing the problem. They said even though it has spark, the charging coils can be bad and that is whats going on. Can anyone confirm this or anyone ever had experience with this problem. Any help would be appreciated. Thanks!

    Kyle


  2. #2
    thesepaperwings's Avatar
    Join Date
    May 2007
    Location
    South East Kansas
    Posts
    1,283
    +1
    1
    I had the same problem and it ended up being my ground. You can test the stator with an ohm meeter. The specs are in the repair manual found in the tech tips section.

  3. #3

    Join Date
    Apr 2008
    Location
    Lock Haven, PA
    Posts
    64
    Did you have a bad ground from the block to the battery? or what should I look for. Let me know.

  4. #4
    thesepaperwings's Avatar
    Join Date
    May 2007
    Location
    South East Kansas
    Posts
    1,283
    +1
    1
    Yep. I had a bad connection that was enough to make it run but not enough to charge it.

    I would just make sure all your wires are tight and clean first.

  5. #5

    Join Date
    Apr 2008
    Location
    Lock Haven, PA
    Posts
    64
    Alright, thanks for the input.

  6. #6
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Other causes woul be a bad voltage regulator. The test procedures for both the regulator and the stator are in the manual. I would start by checking all connections first though.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra 150 battery tie down question
    By xxpaul17xx in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-07-2012, 10:27 PM
  2. ultra 150 battery
    By spotshot in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 03-26-2011, 07:27 AM
  3. 04 ULTRA 150 Battery Issues
    By tonybb in forum Kawasaki How To & FAQs
    Replies: 4
    Last Post: 06-26-2010, 06:39 PM
  4. STX-R charging voltage - battery light flashing
    By ekm in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-30-2009, 07:23 AM
  5. '95 xp 800 battery light flashes
    By gorilla03 in forum 2-Stroke Performance
    Replies: 43
    Last Post: 03-02-2009, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •