Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    Pistonwash's Avatar
    Join Date
    Aug 2005
    Location
    Florida
    Posts
    3,595
    +1
    77

    I (had) a bad pull to the left

    I was breaking in Smoke today...and on a wot run, it started pulling to the left like crazy. I mean bad. So, i am thinking it must be the ride plate...so I was ready to call Jim and bless him out for sending me a jacked up plate.

    Talked to WFO on the phone and I said, "this is pulling waaayyyy worse than any ride plate pull I've ever had." He concurred that it must be the plate...well, it was'nt. The plate is perfect on every measurement.

    Then I found this:
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	acarb1013 001.jpg 
Views:	137 
Size:	1.95 MB 
ID:	116711   Click image for larger version. 

Name:	acarb1013 003.jpg 
Views:	106 
Size:	2.07 MB 
ID:	116712   Click image for larger version. 

Name:	acarb1013 005.jpg 
Views:	150 
Size:	2.01 MB 
ID:	116713  


  2. #2
    Pistonwash's Avatar
    Join Date
    Aug 2005
    Location
    Florida
    Posts
    3,595
    +1
    77
    Can you spot the problem?

  3. #3
    Mike's GPR's Avatar
    Join Date
    Mar 2008
    Location
    Carol Stream, IL
    Posts
    2,044
    +1
    20
    What the hell happened to your sponson. Did you melt it?

  4. #4
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by Mike's GPR View Post
    What the hell happened to your sponson. Did you melt it?
    That's what i was thinking, Mike must be messing with the torch again.

  5. #5
    Pistonwash's Avatar
    Join Date
    Aug 2005
    Location
    Florida
    Posts
    3,595
    +1
    77
    Quote Originally Posted by Mike's GPR View Post
    What the hell happened to your sponson. Did you melt it?
    I did'nt do anything to them, they were like that when I bought it..I did'nt even pay attention when I was dremeling the center hole to step them.

    Paid no attention to the sponsons until today. Put another sponson on from the other ski and no more pull.

  6. #6
    Pistonwash's Avatar
    Join Date
    Aug 2005
    Location
    Florida
    Posts
    3,595
    +1
    77
    Quote Originally Posted by JIM'S PERFORMANCE View Post
    That's what i was thinking.

    The plate is perfect Jim...I am almost scared to pull it up on the trailer in fear of............

  7. #7
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by Pistonwash View Post
    The plate is perfect Jim...I am almost scared to pull it up on the trailer in fear of............
    Looks like you were playing with a torch on that sponson Mike.

  8. #8
    One day at a time..... N8R's Avatar
    Join Date
    Dec 2005
    Location
    TAMPA
    Posts
    3,716
    +1
    41

    Talking

    Quote Originally Posted by Pistonwash View Post
    I did'nt do anything to them, they were like that when I bought it..I did'nt even pay attention when I was dremeling the center hole to step them.

    Paid no attention to the sponsons until today. Put another sponson on from the other ski and no more pull.
    I think it is time for you to head to Lenscrafters

  9. #9
    Fix your tail light you slacker

  10. #10
    If your not doing something, its hard to screw up. stlouisramsfan's Avatar
    Join Date
    Jul 2007
    Location
    Pontoon Beach Illinois
    Posts
    1,115
    Quote Originally Posted by ZMANN View Post
    Fix your tail light you slacker
    LMAO

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pulling to the Left
    By UNSANE in forum 4-Tec Performance
    Replies: 10
    Last Post: 04-21-2011, 08:54 PM
  2. VTS Problem - Pulling to the Left when Trimmed up 100%
    By ImAcoustic in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-17-2008, 02:11 PM
  3. Pulling to the left after being at dealer
    By Chris288 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 06-24-2008, 11:31 AM
  4. Steering pulling to the left / Speedo
    By MrSxy4Ever in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 05-14-2007, 11:36 AM
  5. '06 GPR pulls to the left ?
    By steach in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 08-18-2006, 10:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •