Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 33
  1. #1
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129

    Went rideing today and it sucked

    So i went out rideing today on my ultra 250 was all happy to get back out on the water. took my 10 min stroll out past the no wake zone. Hit the gas and vroooommm it went. Then pop pop pop pop vroooommm pop pop. I was all great. So I slowly made my way back to the launch ramp. It seemed that it ws missing even at a idle. on the way in got it back on the trailer washed it out and went home. I checked the plugs they all looked decent but i have no idea. i am thinking thats the problem but not really sure. any one have any ideas. The ski only has 13 hrs on it. and 100% stock Thanks Tommy


  2. #2
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,161
    +1
    601
    Quote Originally Posted by FIRE0021 View Post
    So i went out rideing today on my ultra 250 was all happy to get back out on the water. took my 10 min stroll out past the no wake zone. Hit the gas and vroooommm it went. Then pop pop pop pop vroooommm pop pop. I was all great. So I slowly made my way back to the launch ramp. It seemed that it ws missing even at a idle. on the way in got it back on the trailer washed it out and went home. I checked the plugs they all looked decent but i have no idea. i am thinking thats the problem but not really sure. any one have any ideas. The ski only has 13 hrs on it. and 100% stock Thanks Tommy
    1st thing I would replace, regardless of hrs

    Def replace plugs, Dont buy the OEM ones

    NGK cr9iex or could be eix cant remember

    THat is 99% of the spluttering probllems


    Waz

  3. #3
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Quote Originally Posted by sirbreaksalot View Post
    1st thing I would replace, regardless of hrs

    Def replace plugs, Dont buy the OEM ones

    NGK cr9iex or could be eix cant remember

    THat is 99% of the spluttering probllems


    Waz
    Ok cool thanks. I guess thees boats like to eat plugs then ? whats the typical life you guys see out of your plugs? one more question could bad fuel cause it to miss also ? its not that old about 3-4 months but wasent sure with it being sc if it was finiky with its fuel. Thanks Tommy

  4. #4
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,161
    +1
    601
    Quote Originally Posted by FIRE0021 View Post
    Ok cool thanks. I guess thees boats like to eat plugs then ? whats the typical life you guys see out of your plugs? one more question could bad fuel cause it to miss also ? its not that old about 3-4 months but wasent sure with it being sc if it was finiky with its fuel. Thanks Tommy

    I get around 20 ish hrs, but I think it depends on your riding conditions, how good you flush/ dry the exhaust out etc

    I pulled my last set out at 20 and kept them for spares

    Waz

  5. #5
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Quote Originally Posted by sirbreaksalot View Post
    I get around 20 ish hrs, but I think it depends on your riding conditions, how good you flush/ dry the exhaust out etc

    I pulled my last set out at 20 and kept them for spares

    Waz
    ok good to know thanks

  6. #6
    AaronC's Avatar
    Join Date
    Aug 2006
    Location
    Sacramento, CA
    Posts
    457
    +1
    4
    Did an exhaust hose pop off a waterbox?

  7. #7
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Quote Originally Posted by AaronC View Post
    Did an exhaust hose pop off a waterbox?
    no never ? But i do wash the inside of my ski after every ride.

  8. #8
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    can't resist the answer is also in search

    don't freak out had to say it

  9. #9
    JET250's Avatar
    Join Date
    Jan 2008
    Location
    Australia mate fair dinkum.
    Posts
    1,278
    +1
    2
    cheeky bugger...love your work cory.

    get used to our bizzare sense of humor dude....sorry but thats us.

    waz, dont foget my new plugs, love you long time.

    i change at 20hrs, cheap insurance when you spend so much time off shore as we ijits.

  10. #10
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Quote Originally Posted by JET250 View Post
    cheeky bugger...love your work cory.

    get used to our bizzare sense of humor dude....sorry but thats us.

    waz, dont foget my new plugs, love you long time.

    i change at 20hrs, cheap insurance when you spend so much time off shore as we ijits.

    That will hapen beeing upside down all the time LOL looks like i need to keep a extra set in the boat box from now on.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Went riding today!!... Top speed 55mph
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 07-09-2007, 06:35 PM
  2. Went Riding today Here a clip
    By ADAMBOMB in forum Videos & Pictures
    Replies: 17
    Last Post: 05-28-2007, 09:03 PM
  3. Went riding today, had some drama...
    By KeithKman in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 01-14-2007, 09:22 PM
  4. Went riding today....took some pics
    By TorquePhoto in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 10-25-2006, 02:57 AM
  5. Went riding today..take a pic :)
    By ADAMBOMB in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 06-16-2006, 01:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •