Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46

    Does this sound ok???

    Hi all, I want some opinions. Im running everything in my sig minus the pro nozzle and my 15/20r is untouched. I added the X charger to my setup this week along with RRFPR and 42s. RRFPR set at 55psi. Took her out today and could only get 7950 RPM after 400m but had to let off. I hit 70.8gps in this distance so i gues it aint hanging around. Now i was expecting it to pull alot harder out of the hole than it did. It is deffinatly quicker in the mid range. just carries on pulling at the same rate. I dont yet have my AF gauge on so not sure if the fueling is right. Could being to rich harm my rpm?? and accel?? Now with the stock charger i was only spinning the prop to 7600ish so iv picked up at least 300rpm. Any1 else that has fitted x charger to there setup what did you get?? I guess i need to get the fuel bang on and then get the pitch bang on 8100. I guess i was just expecting more from the X charger. R88


  2. #2
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    TTT

  3. #3

    Join Date
    Jan 2009
    Location
    tanpa
    Posts
    47
    HI big guy not to sound dome but what is an XS? is that an external IC.if not you need to install one to handle the boost of the Xcharger .the reduction nozzle. GO with 81mm you will get about 1 mile

  4. #4
    baba850r's Avatar
    Join Date
    Sep 2007
    Location
    scotland
    Posts
    673
    +1
    4
    hi rorry not fitted an x-cherger to rxp or that but from working with cossies,evos etc on dyno whether it be engine or hub to rich def does affect performance.

  5. #5
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by baba850r View Post
    hi rorry not fitted an x-cherger to rxp or that but from working with cossies,evos etc on dyno whether it be engine or hub to rich def does affect performance.
    I would not go turning the pressure down until you get an a/f gauge on it. I have no idea what the fueling requirements would be for that set-up in england. It does'nt seem to be running right thats for sure unless your conditions really suck.

  6. #6

    Join Date
    Jan 2009
    Location
    tanpa
    Posts
    47
    your nex mod it has to be an external inter cooler. the stock IC is only a 1.5in opening. I install one on my friend stock 05 rxp and he went from 64.5gps @7800rpm to 68.5gps @8100rpm. The after market IC. is 2.5in so you are going to gain 1 xrta inch plus wheh you take your stock IC. out make sure you get the IC.bockoff from greenhulk it has a hole in the center for your boost gauge I recomend liquid fill analog .I have an 06 rxp [email protected] BUT from time to time it was only turning 7400rpm it turn out to be that my air intake it was leaking .remember when you are wide opend the IC is the most powerfull vacum cleaner in the market.so any water inside your sky is going to get suck in .Iam running a C5 @ 10psi. from RD wich is pretty compatible to your Xcharger

  7. #7
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by speedskixp View Post
    I would not go turning the pressure down until you get an a/f gauge on it. I have no idea what the fueling requirements would be for that set-up in england. It does'nt seem to be running right thats for sure unless your conditions really suck.
    HMMM I need to get the AF gauge sorted. I think that i have got the 3-400 rpm out of the charger that i should have. Just didnt get the hit of accel i was expecting out of the hole. Although in the mid range it is awsome just keeps going. I think with a longer run there is alot more speed in her as it is now. Got a feeling that the wear ring is getting a bit worn so that wont help. Looking at what other people have got with similar kit im not far off just got to get everything tuned in. 1 thing i did notice with the new charger is that the power is instant rather than having to build up. Conditions are cold but the only bit of flat water we got is inside a lil harbour maybe 400m at most long so from standing start I got 71 in this distance. Not to be sniveled at i suppose. I think I need to de pitch i touch to get the rpm straight up to 8100 then im going o see more speed i would think. Im begining to see why you got spend so much time tuning to get the speed. R88

  8. #8
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by seawoolf View Post
    your nex mod it has to be an external inter cooler. the stock IC is only a 1.5in opening. I install one on my friend stock 05 rxp and he went from 64.5gps @7800rpm to 68.5gps @8100rpm. The after market IC. is 2.5in so you are going to gain 1 xrta inch plus wheh you take your stock IC. out make sure you get the IC.bockoff from greenhulk it has a hole in the center for your boost gauge I recomend liquid fill analog .I have an 06 rxp [email protected] BUT from time to time it was only turning 7400rpm it turn out to be that my air intake it was leaking .remember when you are wide opend the IC is the most powerfull vacum cleaner in the market.so any water inside your sky is going to get suck in .Iam running a C5 @ 10psi. from RD wich is pretty compatible to your Xcharger
    I got external IC already see my sig "XS with Bleedline" When you say your intake was leaking?? what you mean?? and what prop are you turning? have you re pitched it atal?

  9. #9
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Right, I have come to the conclusion that I had it running rich. Now I think this coz I think im down on accel which 1 of the engine tuners at work said that running rich will cause this. Also i had a bit of a dead spot in the mid range where i had no throttle response to speak of. Apparently also a symptom of running rich. Would you guys in the know agree with this??

    Im going to have to wait abit as im not going to be able to do any testing for a couple of weekends now. Next time out i will be able to get boost numbers and AF numbers. This will help me diagnose any issues i guess. R88

  10. #10
    sportster's Avatar
    Join Date
    May 2006
    Location
    St.Albert, Alberta, Canada
    Posts
    156
    I would suggest putting the stock injectors in & set the rrfpr to 60 psi. I have the same set up but with a 14/19 because i am at 2500'. My runs between 8000-8150.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Does this sound OK for Carb Tuning?
    By LS2000 Cop in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 10-15-2007, 08:38 PM
  2. Does This Sound OK? Please Help!
    By holdnon72 in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 07-01-2007, 05:36 PM
  3. Does this sound about right?
    By sbogi in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-23-2006, 02:49 PM
  4. does this look ok...??
    By txgp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 07-11-2006, 08:20 PM
  5. 05 pump- does this look ok to you?
    By idizzy in forum Yamaha PWC Performance (2-stroke)
    Replies: 25
    Last Post: 12-10-2005, 05:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •