Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 35
  1. #1

    Servicing GP1300 R

    hello,

    Just bought a 04 GP 1300 R with 85 Hours. I do not have a factory manual and was wondering when is it necessary to service ( oil, filters,hoses, etc) ski?

    Thanks for you help.


  2. #2
    Mike's GPR's Avatar
    Join Date
    Mar 2008
    Location
    Carol Stream, IL
    Posts
    2,044
    +1
    20
    Welcome to GH, you found the best place to answer any question imaginable about the GP1300R. Search the site. Lots of great information. Not sure what you mean by service. Are you looking for maintenance info?

    Did you check compression, is it winterized, does it have waveater clips and a dplate? How bout the pump tunnel, has it been reinforced? Is it running the stock oil pump?

    Any mods done?

  3. #3

    Servicing

    Honestly,

    I am a newbie and do not know much yet. However, I am refering to just general maitenance.

  4. #4
    Mike's GPR's Avatar
    Join Date
    Mar 2008
    Location
    Carol Stream, IL
    Posts
    2,044
    +1
    20
    No problem,

    Start at the beginning.

    Does it run? Does it run as it should? Does it have any mods that you know of or is it completely stock?

  5. #5
    SpeedJunky's Avatar
    Join Date
    Dec 2005
    Location
    Michigan
    Posts
    1,118
    +1
    35
    Manual http://greenhulk.net/forums/showthread.php?t=9546

    Have you taken it for a ride ?

  6. #6

    Join Date
    Jul 2008
    Location
    cape cod
    Posts
    195
    no oil filter, but there is a fuel filter, if you do noy know when it was changed last, i would change it

  7. #7
    completely stock. runs great when Im on the go, however and maybe it's a 2 stroke thing, but when i start it up there's lots of white smoke and it sounds strange (like it wants to shut off) when im in idle . What do you think?

  8. #8
    Mike's GPR's Avatar
    Join Date
    Mar 2008
    Location
    Carol Stream, IL
    Posts
    2,044
    +1
    20
    Quote Originally Posted by cuda167 View Post
    no oil filter, but there is a fuel filter, if you do noy know when it was changed last, i would change it
    I dont think there is a fuel filter on the 1300's??? If there is I would like to know so I can change it!!! There is a water separator though.

  9. #9
    SpeedJunky's Avatar
    Join Date
    Dec 2005
    Location
    Michigan
    Posts
    1,118
    +1
    35
    Any chance you know what kind of oil is in the ski ?

  10. #10
    Mike's GPR's Avatar
    Join Date
    Mar 2008
    Location
    Carol Stream, IL
    Posts
    2,044
    +1
    20
    Quote Originally Posted by dimast View Post
    completely stock. runs great when Im on the go, however and maybe it's a 2 stroke thing, but when i start it up there's lots of white smoke and it sounds strange (like it wants to shut off) when im in idle . What do you think?
    I am assuming stock oil pump since it is completely stock. It sounds like what your experiencing can be normal. Is the white smoke only when you first start it and are first idleing? It sounds like the exhaust is still coming out of your front pissers before they fill with cooling water. That is normal. And a blubbery feeling upon idle is usually normal as well. It does not die out when idleing, correct?

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 10hr service info & questions
    By checkerboard in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-18-2008, 07:20 AM
  2. 10 hour service:' maintenance light'
    By reyes in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-15-2007, 12:30 AM
  3. Bad luck after the 10 hour service?
    By dgmoore in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-09-2005, 08:44 AM
  4. Dealership 10 hr service cost!
    By Compwhiz82 in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-01-2005, 01:56 PM
  5. New RXP'S 10 hour Service
    By Muddy River in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-28-2005, 01:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •