Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    RXPX knock sensor

    hello every one
    the knock sensor on my 08 rxpx finished its life afrer 50 hours.
    is it too soon?
    does the knock sensor identical in all 4-tec models?
    thanks
    oren
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	m_Photo0488.jpg 
Views:	345 
Size:	63.9 KB 
ID:	117363  


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by Jet-Man View Post
    hello every one
    the knock sensor on my 08 rxpx finished its life afrer 50 hours.
    is it too soon?
    does the knock sensor identical in all 4-tec models?
    thanks
    oren
    How do you know the knock sensor went out? What were the symptoms? I have not heard of one going bad but maybe others have.

  3. #3
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,677
    +1
    4
    I don't recall ever hearing of a bad one. Did you get a P0326 error code?

  4. #4

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    Your the FIRST. Lucky guy Look for it being grounded or the plug.

  5. #5
    i guess it doesn`t make me a lucky guy after all.
    the simptoms were power cut and a strong beep. i don`t recall the exact error code. cheking the sensor shows very low resistance (0.8 ohm insted of 4.8-5 as it should be). is there any other option other than replacing it?

  6. #6
    does the knock sensor identical in all 4-tec models?
    thanks
    oren

  7. #7
    I just developed this same problem 2 rides ago. The first time it happened, I assumed I had bad gas, but that's not the case now. My symptoms are: runs great until I hit about 7000rpm, then the engine hesitates, beeps real loud, gives the P0326 error code, and then cuts power. After the code, the ski runs real rough and I can't get up to high speed. If I pull the safety lanyard and then replace it and turn it back on, everything works great. I can run for long periods of time without any errors. After a bunch of experimentation, it looks like going over 7000rpm is the cause. I have not checked the knock sensor itself yet.

  8. #8
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by Jet-Man View Post
    does the knock sensor identical in all 4-tec models?
    thanks
    oren
    Just go to the Order PEM Parts link on the left side of the screen and check the part numbers for various skis. My guess is that they are all the same - just little microphones that "hear" the pinging... Ron

  9. #9

    Join Date
    Mar 2009
    Location
    wesp palm beach
    Posts
    7
    Hello guy i'm new here and i was reading this thread and i have the same error code problem p0326... it is not the gas because i always put BP 97 oc.. i have 54 hours on my rxt 2008 215.... Yesterday i went out with some friends to get some waves and the code come out.. i keep runing .... after 1 hour with the code we went get some rest and i let the ski off for like 20 minutes after i start again we went out again do the same geting waves and having fun for like 2 more hours and the CODE never appear again.. we took the ski to a river and the ski run perfect no code...
    Now what to do??? any help?? any idea how to fix this???
    let me tell u when my ski hit 50 hour the code p0236 came out i took it to the dealer and they said they fix it.... i think p0236 and p0 326 the have some king of relashionship... please any idea any opinion would be great... thank you

  10. #10

    knock sensor

    hey guys, i am relatively new to the forum. i have a 2007 rxt with approx 38 hrs and call it deja vu but i got the same code (p0326) last week when out. 2 second beep and then the revs cut to 7000 rpm max and about 58 mph on the speedo. once lanyard removed it reset. will have to troubleshoot the sensor and connections. hopefully a quick fix. only downfall her in st. thomas, virgin islands is no seadoo dealer and therefore no BUDS if problems are worse.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Where do i find the knock sensor on my RXPX 260 2013?
    By Dexperados in forum 4-Tec Performance
    Replies: 16
    Last Post: 07-21-2014, 02:21 PM
  2. How To: Install RR ECU after the knock sensor update 04 RXP
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 15
    Last Post: 06-14-2008, 12:13 PM
  3. knock sensor going bad?
    By Green Hulk in forum 4-Tec Performance
    Replies: 49
    Last Post: 04-23-2008, 04:30 PM
  4. Knock Sensor
    By meeper in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-08-2005, 10:43 AM
  5. Latch & Knock Sensor Recall
    By rxp_boy in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-01-2005, 04:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •