Results 1 to 4 of 4
  1. #1

    exhaust gas temp sensor

    Do any of you run EGT's on your high proformance skis? If so where do you place the sensor and what is the optimum temp that one should run? Thanks!!

  2. #2
    btldigger's Avatar
    Join Date
    Feb 2007
    lebanon tn.
    I have them on my ultra. Optimal temp will depend on placement. You kind of have to start out reading the plugs and watching the temps to find where its happy. I will attach a few pics to shoe where mine are with the tripples.

    Have you run the pipes yet or are you just setting it up?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC02425.JPG 
Views:	35 
Size:	136.4 KB 
ID:	118026   Click image for larger version. 

Name:	DSC02487.JPG 
Views:	33 
Size:	144.3 KB 
ID:	118027   Click image for larger version. 

Name:	DSC02489.JPG 
Views:	40 
Size:	133.0 KB 
ID:	118028   Click image for larger version. 

Name:	DSC02490.JPG 
Views:	38 
Size:	157.5 KB 
ID:	118029   Click image for larger version. 

Name:	DSC02491.JPG 
Views:	34 
Size:	144.0 KB 
ID:	118030  

  3. #3
    The ski was up and running when I bought it a few months ago but was on race gas. It also had a couple base gaskets that were leaking and was very very nasty under the seat.
    I am in the process of cleaning it up and putting it on pump gas at the moment. Steve has my cylinders thought while I had it down I would do a top end rebuild and dress her up the best I could and thought I would add a few gadgets.
    Can you give me more details on your EGT setup? What brand, temp to look for, cost etc. Thanks!!

  4. #4

    Join Date
    Sep 2006
    down under
    seadoo single pipes, up to 1300

    High port franco shhhhhit, over 950 lost power.

    Fook em off and find a decent tuner. Aint used them for 5 yrs and still build engines.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB Ultra 150 exhaust pipe temp sensor
    By x2ryder in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 04-22-2011, 05:07 PM
  2. anybody used a EGT- exhaust gas temperture sensor on a fuji engine?
    By andy95'slx780 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 11-01-2010, 12:48 PM
  3. Exhaust over temp sensor
    By boosted-delslow in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-30-2010, 01:21 PM
  4. exhaust water temp sensor
    By born riding in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 08-18-2008, 11:34 PM
  5. Exhaust temp sensor relocation???
    By CRS in forum 4-Tec Performance
    Replies: 13
    Last Post: 09-11-2005, 07:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts