Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14

Thread: Take a look

  1. #1

    Take a look

    Hi people
    look what had hapened to my plug
    i was riding at half throtle...feel the engine low the rpm i stoped remove the plugs and what a surprise......check the compression and zero on 3 cilinder
    what caused this?
    thx
    Hugo
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20022009222.jpg 
Views:	51 
Size:	498.3 KB 
ID:	118110  


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    What year ski? My guess is a valve... Ron

  3. #3
    It,s RXT 2005 w/ ferrea valves..the Plugs are denso iridium 27 with 2 months of use

  4. #4
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    if something broke and caused it to have zero compression on that cylinder, I would think that the ground electrode would at least be bent.

  5. #5
    the ground electrode isnīt damage... no bent...nothing itīs in good conditions, iīm now removing the head to see how it is.thatīs strange no bent on ground electrode, only the insulator is half broke
    thx

  6. #6
    SeaGoat's Avatar
    Join Date
    Jun 2008
    Location
    Jacksonville, N.C.
    Posts
    2,214
    +1
    2
    I think the insulator got hot and cracked. Running lean maybe. What stage are you running with Ferrea valves? What boost and most importantly, what AFR? Cracked insulators are a sign of heat damage usually.

  7. #7
    My AFR is about 12/12.5, my boost around 14/14.5 psi at 8600 RPM, the plug ground electrode isnt melted
    thx
    Hugo

  8. #8
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    defective spark plug... my denso's went out after 10 hours. Go back to NGK plugs they work great!

  9. #9
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    valve would be my guess.

  10. #10
    The valves are ok, only the lip of piston is damaged as you can see by the pictures
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20022009224.jpg 
Views:	78 
Size:	740.7 KB 
ID:	118129   Click image for larger version. 

Name:	21022009227.jpg 
Views:	45 
Size:	782.7 KB 
ID:	118130  

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ski's almost done take a look guys
    By mikegpr03 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 12-27-2006, 07:35 PM
  2. Take A Look
    By mobbys in forum 4-Tec Performance
    Replies: 32
    Last Post: 12-15-2006, 06:55 PM
  3. Just back from powder coating take a look
    By mikegpr03 in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 11-21-2006, 12:23 AM
  4. Gentlemen, just take a look!
    By scittb in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 10-22-2006, 09:31 PM
  5. Take a look at this!....A bit graphic...
    By GeoRXT in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 06-30-2006, 12:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •