Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1
    Never say never KirkF350's Avatar
    Join Date
    Jun 2005
    Location
    Midlothian, Texas
    Posts
    4,433
    +1
    3

    Strange noise on RXPX

    I went out riding today and noticed a noise. While riding, not at idle, but anywhere from 2000 RPM on up, I notice what could best be described as a rattling of sorts coming from the ski. Maybe even like rocks being shaken in a box. It sounded like it was coming from the engine compartment but it was hard to tell. The ski has 5 hours on it and is stock other than the R&D grate that I installed yesterday. No cavitation, and other than the noise, the ski runs great. Before I installed the grate, I had a best speed of 68.9 hitting 8180 RPMs. Today, I was all over the rev limiter at 71.6. And speaking of the rev limiter, when you hit 8200, how much should the limiter back the ski down? I would loose 20-60 rpm each time I would hit 8200.
    Just to be safe, I was already planning on changing out my washers but do I have something else going on?


  2. #2
    mtrager's Avatar
    Join Date
    Jul 2006
    Location
    Orlando, Florida, United States
    Posts
    2,443
    +1
    2
    Kirk,

    Thats what the x's do when they hit the limiter.

  3. #3

    Join Date
    Jul 2005
    Location
    Lake Dunlap, Texas
    Posts
    1,600
    +1
    28
    It already has steel washers.

  4. #4
    Never say never KirkF350's Avatar
    Join Date
    Jun 2005
    Location
    Midlothian, Texas
    Posts
    4,433
    +1
    3
    Quote Originally Posted by Sundance View Post
    It already has steel washers.
    I know but I have read where a few people have lost those.

  5. #5
    Never say never KirkF350's Avatar
    Join Date
    Jun 2005
    Location
    Midlothian, Texas
    Posts
    4,433
    +1
    3
    Quote Originally Posted by mtrager View Post
    Kirk,

    Thats what the x's do when they hit the limiter.
    I figured that was the case, my main concern though is the noise.

  6. #6
    tweeker's Avatar
    Join Date
    Jul 2007
    Location
    Denver NC
    Posts
    706
    +1
    45
    My X had the same noise I just ran the pee out of it never had any trouble and sold it at 60 hours

  7. #7
    mtrager's Avatar
    Join Date
    Jul 2006
    Location
    Orlando, Florida, United States
    Posts
    2,443
    +1
    2
    The washers would not be bad and do those rpms.

  8. #8
    THE OFFICAL SUPERDUTY!!!!!! superduty's Avatar
    Join Date
    May 2006
    Location
    Webster, Texas
    Posts
    4,726
    +1
    5
    u need to bend ur prop, and bring ur rpms back to 8100

  9. #9
    MPower's Avatar
    Join Date
    May 2005
    Location
    Raleigh, NC
    Posts
    3,338
    +1
    121
    When the cage on my charger bearings broke apart it caused the wheel to touchdown and caused a similar noise to the one you are describing, but performance was still good. Not an hour later it completely failed and the charger wouldn't make boost.

    This seems rare so may not be your problem, but pull you hose from the charger to the cooler and inspect for a gray dust which would indicate your wheel is touching down.

  10. #10
    Never say never KirkF350's Avatar
    Join Date
    Jun 2005
    Location
    Midlothian, Texas
    Posts
    4,433
    +1
    3
    Quote Originally Posted by MPower View Post
    This seems rare so may not be your problem, but pull you hose from the charger to the cooler and inspect for a gray dust which would indicate your wheel is touching down.
    Will do! Thanks for the advise.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. bogs and strange noise on 94 Polaris SL 650
    By cwbysfan03 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-19-2015, 10:51 AM
  2. Ultra300X strange noise on deceleration
    By 1390 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 16
    Last Post: 10-03-2014, 02:45 PM
  3. Strange noise on FX SHO 2010
    By DarkPiranha in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 07-23-2013, 01:59 AM
  4. strange noise on 2005 rxp
    By pantydropper in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-23-2010, 11:47 AM
  5. noise on rxpx found!!
    By IM2FAST4U in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-26-2008, 11:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •