Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128

    Input on setup and top speed, Stg 3+ & OL

    My setup from last year is in my signature, which ran 81 mph most days. I am getting after my winter upgrades and wondered if people had input or experience with the changes I am doing and what they think it will run, or if the setup is OK.

    I am adding the ET 137 impeller and spacer to my stock X charger, Jims open loop plate, open loop cooling (or heat exchanger if anyone has data) and likely a 15/22R prop. I also have Ferrea valves and will be doing a valve job, decking the head and new head gasket just for insurance. Still running the Riva ECU but will likely add 55 lb injectors for insurance since I sometimes run in cool weather. The ET 137 X charger upgrade seems to run similar numbers to the Rude1, so I think the Riva ECU and 55s should be more than enough fuel.

    Input or estimates on top speed on this setup?


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by Vern View Post
    My setup from last year is in my signature, which ran 81 mph most days. I am getting after my winter upgrades and wondered if people had input or experience with the changes I am doing and what they think it will run, or if the setup is OK.

    I am adding the ET 137 impeller and spacer to my stock X charger, Jims open loop plate, open loop cooling (or heat exchanger if anyone has data) and likely a 15/22R prop. I also have Ferrea valves and will be doing a valve job, decking the head and new head gasket just for insurance. Still running the Riva ECU but will likely add 55 lb injectors for insurance since I sometimes run in cool weather. The ET 137 X charger upgrade seems to run similar numbers to the Rude1, so I think the Riva ECU and 55s should be more than enough fuel.

    Input or estimates on top speed on this setup?

    I would leave the 50's and run a RRFPR...

  3. #3

    Join Date
    Aug 2006
    Location
    Gonzales, La
    Posts
    2,145
    +1
    9
    83

  4. #4
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Danny, I already have 55s, but I still may take your advice ... will have to monitor AFR and see how it behaves. Others have run Rude1 with Riva ECU and 50s, switching to 55s if it was cold and AFR was good.

    Mike, I am hoping for more ... the ET or Riva upgrade wheels added 1.5 to 2.3 mph to other skis. The open loop plate usually adds 3+ mph over the stock plate, sometimes 4 mph when adding open loop cooling as well. But, was looking for input from others who have added open loop/open loop plate or the X charger upgrade wheels to see whats real ...

  5. #5

    Join Date
    Aug 2006
    Location
    Gonzales, La
    Posts
    2,145
    +1
    9
    Quote Originally Posted by Vern View Post
    Mike, I am hoping for more ... the ET or Riva upgrade wheels added 1.5 to 2.3 mph to other skis. The open loop plate usually adds 3+ mph over the stock plate, sometimes 4 mph when adding open loop cooling as well. But, was looking for input from others who have added open loop/open loop plate or the X charger upgrade wheels to see whats real ...
    I missed the rideplate. I'm saying 85 now.

    Be careful with the open loop cooling. I'm hearing about cylinder contraction causing piston problems. Turns out the thermostat is there for a reason after all.

  6. #6
    if u deck the head u should deck the block if not u might run into problems getting the head gasket to seal, the block and head will cure together when breaking in a new motor so they match, when u deck the head it become stright again and it might not match up with the block unless u deck the block also i've seen it happen

  7. #7
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by engineermike View Post
    Be careful with the open loop cooling. I'm hearing about cylinder contraction causing piston problems.
    Mike could you please elaborate more on this??What temps and conditions were they???How many have you heard of this happening to??Thanks Man!!!

  8. #8
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6
    Quote Originally Posted by Snoman View Post
    Mike could you please elaborate more on this??What temps and conditions were they???How many have you heard of this happening to??Thanks Man!!!
    I knew that comment was going to get some interest. I am curious to hear more about this also.

  9. #9
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    From what I remember is that the expansion of the sleeve and piston is not uniform if the coolant flow is too fast and too cold. The sleeve will not expand fast enough or NOT enough, causing issue with the piston which is not affected by the coolant...And I think if it runs too cold, the computer will keep dumping more fuel to warm it up, making it constantly rich...

    No one has been able to figure out what the optimum operating tempurature of the motor is yet...But you have to figure that with the Rotax Racing Thermo (158 and 131 degree), you CAN bring it down to a point...

  10. #10
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by Danny View Post
    From what I remember is that the expansion of the sleeve and piston is not uniform if the coolant flow is too fast and too cold. The sleeve will not expand fast enough or NOT enough, causing issue with the piston...And I think if it runs too cold, the computer will keep dumping more fuel to warm it up, making it constantly rich...

    No one has been able to figure out what the optimum operating tempurature of the motor is yet...But you have to figure that with the Rotax Racing Thermo (158 and 131 degree), you CAN bring it down to a point...
    Ya I got that part.. I know what it means...Im wondering how many people and what kinda conditions this is happening in...Is it in warm weather like we normaly ride (80-85 degree water and 82-95 degree air temp) OR is it 50 degree air and water temps were people are out testing/running..Also are these guys monitering their engine temps and adjusting accordingly??? Optimal engine temp is between 165 to 180 depending on conditions..This will intern be hot enough to get your oil up to operating temp also...

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How many hours and top speed on your RXP 300 ?
    By rxp300norway in forum 4-Tec Performance
    Replies: 34
    Last Post: 06-04-2016, 05:34 PM
  2. The effect of air conditions on ECU, RPM, performance, and top speed
    By pyroseth in forum Kawasaki PWC Performance (4-stroke)
    Replies: 14
    Last Post: 05-14-2015, 01:07 PM
  3. Low RPM 7700 and Top Speed 70 with S3 and C5 SC's on 04 RXP
    By snowrunner in forum 4-Tec Performance
    Replies: 24
    Last Post: 06-23-2009, 08:54 AM
  4. RXP-X Loss of acceleration and top speed
    By laarben in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-31-2008, 03:15 PM
  5. Whats going on with my Top Speed?? RPM ???
    By Sosa62 in forum 4-Tec Performance
    Replies: 44
    Last Post: 10-23-2007, 01:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •