Results 1 to 6 of 6
  1. #1

    Join Date
    Jul 2008
    Location
    ENGLAND
    Posts
    605

    dodgy thermostat

    while modding my ski during the last 12 months i added the riva thermo, had it installed by my dealer,got PO116 code,it would clear then next time out same code,and so on.Today i had it removed and replaced,and water tested,its fine.I tested the riva therm against the standard in a pan of hot water and the standard opened first every time....10 times...warm, hot and very hot(boiling water) water the standard was best(faster) opened sooner,guess it was faulty as it was only 2/3 months old,checked head gasket,ok,but it could have caused more probs.Anyone else had any probs? im going back to RIVA but im not holding my breath.


  2. #2
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,761
    +1
    29

    Thumbs up

    I just dont run one. Never worry about it stickin. I just refuse to learn,,,as Jerry would say. I`m hard headed and drunk! Happy Mardi Gras u mutha phucas!

  3. #3
    piper250's Avatar
    Join Date
    Sep 2006
    Location
    Claytor Lake, Dublin Va.
    Posts
    94

    riva thermostat

    I have been having a problem for a while. Everytime I go out I have to let my RXT warm up slow or it blows out water from the overflow. After it warms up I can run it wide open all day and not have a problem. I am going to pull it and so the test you did. It is the riva set up. If it is bad I talked to Bubba and I know they will take care of it. They are great people to deal with.

  4. #4

    RIVA

    We had many times overflow w/ riva thermostat we removed and the problem was gone

  5. #5

    Join Date
    Jul 2008
    Location
    ENGLAND
    Posts
    605
    Quote Originally Posted by piper250 View Post
    I have been having a problem for a while. Everytime I go out I have to let my RXT warm up slow or it blows out water from the overflow. After it warms up I can run it wide open all day and not have a problem. I am going to pull it and so the test you did. It is the riva set up. If it is bad I talked to Bubba and I know they will take care of it. They are great people to deal with.
    THAT IS EXCACTLY WHAT HAPPENED TO ME....EXCACTLY,ive gone back to standard and im good

  6. #6

    Join Date
    Jul 2008
    Location
    ENGLAND
    Posts
    605
    Quote Originally Posted by churras View Post
    We had many times overflow w/ riva thermostat we removed and the problem was gone
    +1 im standard and cured

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 158 Thermostat question...
    By rx4pain in forum 4-Tec Performance
    Replies: 34
    Last Post: 11-21-2008, 10:36 PM
  2. Rotax Racing 158 degree thermostat
    By Green Hulk in forum 4-Tec Performance
    Replies: 22
    Last Post: 07-09-2008, 02:15 PM
  3. 158 degree thermostat
    By Sundance in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-11-2005, 06:45 PM
  4. rr thermostat
    By peter in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-06-2005, 03:43 PM
  5. thermostat
    By peter in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-01-2005, 04:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •