Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    Join Date
    Jun 2008
    Location
    Manado, Indonesia
    Posts
    33

    2008 RXT-X power loss, experts advice needed..

    Hey guys this is my first post on this forum, long time reader and first time poster..

    I got a problem with my sky last sunday, my ski is almost 70 hours now..
    I already change the oil and oil filter twice now, and the problem is I got a sudden power loss on my ski while riding it.
    I feel the rpm is kind of stuck somewhere around 6k - 7k because it wont pull as hard as usual, I can not test the exact max rpm where it stuck because the wave is so big.
    One thing for sure I can go WOT with only one hand holding the handle bar, which usually I would just backflip and fall.
    While riding I feel something got sucked into the pump, the ski vibrate and give the usual sound when something got sucked. But the vibrate and the sound just disappear instantly and also my power.
    Then the next day after checking all the pump and other thing I changed the wear ring because there's alot of deep scuff in it and also change the spark plug, tested it and it feels better but still quite a lot still missing with the power..
    I dunno what else to do, please someone help me
    and if you would mind explain to me the step by step, because I got no dealer around me so basically I have to do it all alone.
    Thanks


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    The first thing I would do is see if any of the SC hoses between the SC, IC and TB have blown off or split. next I would pill off the hose to the SC and see it you can rotate the SC impeller with your fingers. If it spins, the SC washers are bad.

    What are you going to do when you have to have a dealer do the 100 hour SC maintenance?... Ron

  3. #3
    SeaGoat's Avatar
    Join Date
    Jun 2008
    Location
    Jacksonville, N.C.
    Posts
    2,214
    +1
    2
    Pull the hose off going to your supercharger from the air intake and reach in and see if you can turn the supercharger impellor with your fingers. If you can then your clutch washers went out and you need to rebuild the supercharger. There have been a few failures of the 08 metal clutch washers on the "X" ski's.

    Damn, I type too slow.

  4. #4

    Join Date
    Jun 2008
    Location
    Manado, Indonesia
    Posts
    33
    Quote Originally Posted by King_Of_Fun View Post
    The first thing I would do is see if any of the SC hoses between the SC, IC and TB have blown off or split. next I would pill off the hose to the SC and see it you can rotate the SC impeller with your fingers. If it spins, the SC washers are bad.

    What are you going to do when you have to have a dealer do the 100 hour SC maintenance?... Ron
    Thanks for the quick response,
    About the 100hr SC service I guess I have to do it myself, I got no other choices. The only way I would get it to a dealer is on a 3,5hr flight to singapore.. >_<

    About the SC, I will inspect more carefully one more time to see if there is any broken hoses, and I will check the SC impeller also..

    And IF I came back with nothing on the hoses and the impeller ( the impeller needs a lot force to turn it with hand ) is there any other suspect to this ?

  5. #5
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    check the simple things first (I am sure you have)

    1- check your throttle cable hold it wide open (while off) then make sure the throttle body is open all the way
    2- as above check all hoses
    3- check the SC fan for slip
    4- look under the ski and in the tunnel for trash

  6. #6
    wickedpony2007's Avatar
    Join Date
    Feb 2008
    Location
    Virginia beach
    Posts
    176
    I had a problem with my RXT-X at upper 40's hours. it lost pwr. has a weird noise. turned out to be the most outer bearing was going out. the washers were good, still hard to turn by hand. had to pull the supercharger to see the damage. the dealer replace it with a new unit.
    good luck on yours!!! hope you find the problem!

  7. #7

    Join Date
    Jun 2008
    Location
    Manado, Indonesia
    Posts
    33
    I tested to turn the SC impeller and I can turn it with only my fingers.. I guess I got a SC failure..
    What do I have to do next ? Is there any spesific guide to do this on the X-ski ?
    I guess I will have to do it all on my own, so if there is a spesific X-ski step by step SC rebuild would be really appreciate..
    I already use the search function, and all I can find is non X-ski.. Is it the same with the X-ski ?

  8. #8
    I havent repaired a SC failure on an 08 or newer ski with metal washers......but I have done many 04-07 ceramic washer failures.

    I do not recommend you run the ski anymore untill you repair!

    pull the supercharger out to get an idea of what is missing (1 washer, 2 or both)

    remove the front oil pump and see if it is scarred ( if the front one is scarred then you know the back one is)

    then remove the cam to see if the head is scarred from the debris

    if the head is fine then just replace the oil pumps and flush the engine fully

    if the head is scarred then you need to dissasemble the engine and replace all bearings, get a new head and preferably a new cam

    I could go into alot more detail but I would be typing all night

  9. #9

    Join Date
    Jun 2008
    Location
    Manado, Indonesia
    Posts
    33
    If the impeller can spin freely, is it have to be beacause of the washer ?
    Isn't there any other reason that might cause this ?

    I dont think the new metal washer could just dissapear right, it's suppose to be tougher than the ceramic one

    What if I just buy the complete OEM X charger kit ? Would replace it will cure the problem instantly ?

  10. #10
    SeaGoat's Avatar
    Join Date
    Jun 2008
    Location
    Jacksonville, N.C.
    Posts
    2,214
    +1
    2
    Just remove the supercharger and check to see if all the parts are intact. I think it's probably just slipping. Then send it to Jerry for a rebuild if in the states or order an 08 rebuild kit if not.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engine experts!!! Advice needed!!
    By tocullo in forum 4-Tec Performance
    Replies: 61
    Last Post: 08-08-2013, 05:02 PM
  2. Rush expert advice needed! GP1300R Runaway?
    By chris1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 37
    Last Post: 05-24-2013, 09:52 AM
  3. Expert advice needed on d-plate install!!!
    By cisco4449 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 09-25-2012, 01:13 PM
  4. 2008 gtx-215 power loss
    By dallasquick in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-16-2009, 09:32 PM
  5. 2008 gtx-215 power loss
    By dallasquick in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-16-2009, 09:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •