Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 51
  1. #1
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38

    My Free Toy- RXP

    So I picked up my bosses 04 RXP supercharged ski today, He gave it to me and 4 other people in the office but with their lack of interest with boats, pwc's and all, its pretty much mine and another guy that just happens to own a ski already so it worked out great.

    I would say it has never been washed and has some dings and scratches but hey, it was free right?? It has about 89 hours on it and runs great. The only issue that I found so far is the VTS does not read anything on the info gauge nor does it move. Im thinking a fuse or its the whole vts module that is bad. The info gauge does flash "sensor error" But I dont know how to find out what that is for.

    I plan to also replace the supercharger washers to metal ones, change the pump grease and engine oil.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	0228091421-00.jpg 
Views:	120 
Size:	245.1 KB 
ID:	119249  


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by Pwgsx View Post
    So I picked up my bosses 04 RXP supercharged ski today, He gave it to me and 4 other people in the office but with their lack of interest with boats, pwc's and all, its pretty much mine and another guy that just happens to own a ski already so it worked out great.

    I would say it has never been washed and has some dings and scratches but hey, it was free right?? It has about 89 hours on it and runs great. The only issue that I found so far is the VTS does not read anything on the info gauge nor does it move. Im thinking a fuse or its the whole vts module that is bad. The info gauge does flash "sensor error" But I dont know how to find out what that is for.

    I plan to also replace the supercharger washers to metal ones, change the pump grease and engine oil.
    Sweet deal You may need to have a dealer check out the VTS issue... if it shows nothing on the cluster, the VTS option may need to be activated through the MPEM with the BUDS s.w. I've heard about this issue before if the battery has been removed, or dead for some time

  3. #3
    Ziggy's Avatar
    Join Date
    Feb 2006
    Location
    NE Ohio
    Posts
    1,150
    +1
    3
    There's an od saying that goes "Access is better than ownership"

    If you break it do you pay for it?

    Your boss is definitely cooler than mine! (cranky old bass fisherman)

  4. #4
    Never say never KirkF350's Avatar
    Join Date
    Jun 2005
    Location
    Midlothian, Texas
    Posts
    4,433
    +1
    3
    Wow. Congrats.

  5. #5
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    Quote Originally Posted by Ziggy View Post
    There's an od saying that goes "Access is better than ownership"

    If you break it do you pay for it?

    Your boss is definitely cooler than mine! (cranky old bass fisherman)

    We will see, it needs to be registered and we will ask if he is giving us the title.

    The battery was removed this past winter and we had to put it back into the ski to start it and drive it to the boat ramp. Thats when I noticed the VTS not showing up.

  6. #6
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    In some states, the craft must be registered to you in order for you to insure it. And I wouldn't run an RXP without at least liabiility insurance... Ron

  7. #7
    meansvt00's Avatar
    Join Date
    Jul 2007
    Location
    New Jersey
    Posts
    237
    sweet deal

    Hey if its free its for me

  8. #8
    SeaGoat's Avatar
    Join Date
    Jun 2008
    Location
    Jacksonville, N.C.
    Posts
    2,214
    +1
    2
    Awesome deal! Take some rubbing compound to it and it will shine right up.

  9. #9
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,567
    +1
    4,784
    Quote Originally Posted by King_Of_Fun View Post
    In some states, the craft must be registered to you in order for you to insure it. And I wouldn't run an RXP without at least liabiility insurance... Ron
    +1, good point, make sure it's insured because personal liability is a big issue also people like to steal 'em! Nice gift, just in time for summer!

  10. #10
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    VTS - check the fuse first, but the motors often get water in them and go bad ... my guess is it is toast. Not too tough to replace and cost is around $150 I think.

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My new toy why I have been pre occupied
    By andreas in forum Other Toys
    Replies: 34
    Last Post: 11-23-2006, 06:15 PM
  2. My new toy...
    By GeoRXT in forum Other Toys
    Replies: 5
    Last Post: 08-19-2006, 09:21 AM
  3. My stage 2 RXP, 75.5+mph at 7900 rpms, yahoo!
    By Vern in forum 4-Tec Performance
    Replies: 23
    Last Post: 06-21-2006, 11:10 PM
  4. Here are some of my other toys
    By Capt Walker in forum Other Toys
    Replies: 22
    Last Post: 04-30-2006, 07:49 AM
  5. Check out my new TOY!!
    By Water4fire in forum Other Toys
    Replies: 8
    Last Post: 11-15-2005, 08:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •