Results 1 to 8 of 8
  1. #1
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846

    Noise from pump??

    Hello,
    Had a question about my buddys 2001 GP1200R.
    Under hard exceleration He gets a screeching noise from the pump area.
    Also the RPMs max out and the ski doesnt go .. The ski feels like its cavatating but its hard to say. I rode it and as long as you baby the throttle it will go, but hit the gas hard and it sounds bad..NO mods on ski except for the D-plate.
    Thanks
    Scott


  2. #2
    philip_gpr's Avatar
    Join Date
    Dec 2005
    Location
    Canada
    Posts
    2,724
    +1
    3
    good chance the splines on the intermediate shaft and driveshaft are badly worn (if this is the case pretty soon the ski will stop moving entirely)

    pull the pump assembly out and take a look

    you can download a shop manual from the links in my signature block on the Riva forum

    http://rivaforums.com/eve/ubb.x/a/tp...4/m/9511019071

    I usually have used intermediate shafts for sale

    [email protected]

  3. #3
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Welcome to the Forum snoman

  4. #4
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Thanks Philip..Thats kinda what i thought was the splines but i dont know the yamas to well.Didnt know if they had splines or not.I will get back to you on the shaft .Is that all i will need or is there something else that goes along with that As in Prop ??Possible cost damage to wallet???
    Then again its his wallet right???Thanks again

  5. #5
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Thanks RX951. Glad to be here

  6. #6
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Probably both shafts, internal and external. Prop "may" be okay, but if it's been in there a while, it probably has rock damage.

    If you have to replace the internal shaft...
    I suggest your friend consider doing the 2" pump extention at this time.
    Go to the tech section and look for it.

    If the pump is wore out, or chipped...
    I suggest your friend consider the 05 pump and a dynafly prop and extention.

    If the pump is good, and the prop is wore...
    I suggest you go with a depitched 14/20 or a 13/19 setback and the 2" extention.

  7. #7
    Old Ski Insanity w/rpm500's Avatar
    Join Date
    Aug 2005
    Location
    Crystal River Fl
    Posts
    2,208
    could also be a bearing screech .. has a flat spot and binding under load or the there being to much wear in them and the impeller hitting the housing... exess wear in the liner may be a tell tail of this.

  8. #8
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Hydrotoys,
    The 05 pump will definatly bolt up with no problems on his 01??
    IF so i will let him know I will try to direct him to this site ...He is not a internet gooroo though.But i thank all of you for the responces and ill try
    soon to get it apart ..Thanks again
    Scott

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. noise from pump area and vibration
    By kawaka in forum Kawasaki How To & FAQs
    Replies: 12
    Last Post: 10-18-2015, 04:43 PM
  2. 2001 genesis bad noise from pump
    By cem in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-17-2010, 04:29 PM
  3. Noise coming from pump when running on hose...
    By FrankieV123 in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-25-2009, 05:11 PM
  4. HELP...250x noise from pump area
    By ksalles in forum Kawasaki PWC Performance (4-stroke)
    Replies: 40
    Last Post: 07-12-2009, 10:27 PM
  5. Noise from pump Question ?
    By elviswongg in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 06-30-2009, 05:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •