Results 1 to 2 of 2
  1. #1

    A little help...

    My 05' rxp has been sitting for about 5 or 6 months waiting for the hull to be repaired. I was wondering if there is anything i could do to make sure that i dont have any moisture in it (i didnt winterize it because i thought i would get it repaired sooner). I dont want the motor to lock up or drop a valve. I only have 9 hours on a brand new motor from the factory. Any input would help, thanks.


  2. #2

    Join Date
    Jul 2008
    Location
    ENGLAND
    Posts
    605
    Quote Originally Posted by BuckeyeRxP0384 View Post
    My 05' rxp has been sitting for about 5 or 6 months waiting for the hull to be repaired. I was wondering if there is anything i could do to make sure that i dont have any moisture in it (i didnt winterize it because i thought i would get it repaired sooner). I dont want the motor to lock up or drop a valve. I only have 9 hours on a brand new motor from the factory. Any input would help, thanks.
    I WOULD,remove plugs,and spray bombardier lube down,dont be shy with it,maybe remove the petrol,check the fuel filter,oil,spray the engine with a lube,grease all cables and bare metal surfaces inside and outside the boat.CHECK THE BATTERY,maybe trickle charge it,and generally check all moving parts,throttle,reverse,stearing ect,if your stored in a garage remove the seat open the front keep air circulating,you should be ok.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need a little help please...
    By lafjax in forum 4-Tec Performance
    Replies: 18
    Last Post: 09-08-2006, 07:00 PM
  2. A little help needed
    By Top banana in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-07-2006, 03:12 AM
  3. Need a little help from all your HULKsters!
    By beachboy66 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-20-2006, 07:38 AM
  4. Little help please
    By CRAZEDRXP in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 06-01-2006, 02:38 PM
  5. Can some one Post! A little Help Please!
    By Angelse68cal in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-04-2005, 07:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •