Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407

    Starter Relay WTF??

    Why are these such a problem?


    Small setback today. The starter relay is just clicking. Battery is tested good. Jump the terminals and she fires right up.. Removed the + wires and hit start and I get continuity? clean and reinstall wires same thing click.. jump the terminals and she starts. Went to the auto parts store and picked up a universal starter relay wire it all up and it freaks out the MPED and say check engine.. So back to square one and reinstall the doo one and same results. I think it is time to get a new relay..


  2. #2
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by beerdart View Post
    Why are these such a problem?


    Small setback today. The starter relay is just clicking. Battery is tested good. Jump the terminals and she fires right up.. Removed the + wires and hit start and I get continuity? clean and reinstall wires same thing click.. jump the terminals and she starts. Went to the auto parts store and picked up a universal starter relay wire it all up and it freaks out the MPED and say check engine.. So back to square one and reinstall the doo one and same results. I think it is time to get a new relay..
    Sounds like burnt contacts in the relay. Is it just a plain SPST Bosch relay??

  3. #3
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    Yes, this is common. Welcome to the 4-tec world Beerdart Luckily they're "only" approx. $40..

  4. #4
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    just carry around good pliers with nice thick grips with no holes in them to jump the relay... that's your new "key" .... haha

  5. #5
    Fastest in my cove sfackett0's Avatar
    Join Date
    Aug 2007
    Location
    Sparrows Point, MD (near the Key Bridge)
    Posts
    1,000
    +1
    22
    I bought a marine relay from the company Standard, almost identical only difference is that it had screw post connectors instead of the plug harness, havent had a problem yet. Bet part is that it is only $14

    http://www.standardbrand.com/web_app...mp_bgbulk.aspx

    use the link and type in part# SS605 or SS610 its early and cant remember which one has the correct orientation.

  6. #6
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    It's the SS605... Ron

  7. #7
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    OK last night I took the little bastage apart and cleaned/sanded the contacts I will try is today..

  8. #8
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Reinstalled the relay and she works good as new.

  9. #9
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    Quote Originally Posted by beerdart View Post
    OK last night I took the little bastage apart and cleaned/sanded the contacts I will try is today..
    ...and that didn't cost you anything. Good news!

  10. #10
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,069
    +1
    790
    Quote Originally Posted by sfackett0 View Post
    I bought a marine relay from the company Standard, almost identical only difference is that it had screw post connectors instead of the plug harness, havent had a problem yet. Bet part is that it is only $14

    http://www.standardbrand.com/web_app...mp_bgbulk.aspx

    use the link and type in part# SS605 or SS610 its early and cant remember which one has the correct orientation.

    Thanks for the input. I have had to buy a couple.


    /

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wierd Starter relay problem....NEED HELP???
    By jitees in forum 4-Tec Performance
    Replies: 18
    Last Post: 03-20-2010, 06:19 PM
  2. Starter relay prob... maybe something else?
    By BlitzK in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 05-26-2008, 12:12 PM
  3. Why does Starter relay keep going bad?
    By camar0 in forum 4-Tec Performance
    Replies: 7
    Last Post: 02-02-2008, 09:59 PM
  4. Universal Starter Relay
    By howie099 in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 07-03-2007, 04:30 PM
  5. Battery & Starter Relay Troubleshooting
    By 1FastTrespiper in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-06-2006, 10:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •