Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    04 RXP pump nose cone removal

    In the faq section it says that some pump nose cones are threaded and some not depending on year. can anyone tell me if the pump cone in the 04 rxp is threaded or do I just pull it off


  2. #2
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    it's threaded. look at it close and it will show the direction to turn to remove.

  3. #3
    right on the cone? turn with a channel lock

  4. #4
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    yep, it's molded in. threads backwards...

  5. #5

  6. #6

    Water in grease

    I just pulled mine off Saturday to re-pack with grease. Both of my 04's are not threaded. However, I found water in the pump grease on one of them. Both O-rings were seated and appeared to be OK after inspection. Cone looks fine. Where else could this water be coming from? Bearings didn't show any rust but grease was grey from water contamination. Only run them in fresh water. Any help or ideas on how to keep this from happening again would be appreciated.

  7. #7
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,677
    +1
    4
    I think we are mixing two different items here. The 4-Tec pump cone is not threaded. It has two o-rings and three hex head bolts holding it in place. The 4-Tec impeller cone is threaded (reverse thread) if it is a 215/255 hp RXP/RXT/GTX model, and not threaded if it is a 155/185 hp GTX model.

  8. #8

    OOP's

    I should have read that post more carefully.

  9. #9
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    Quote Originally Posted by barefoot1 View Post
    I should have read that post more carefully.
    it's easy to confuse the terms people use for those two parts. sea doo calls the one at the impeller an impeller boot and the cone that holds grease an impeller cover, most call them nose cone and pump cone. his asking about threads was the clue as to which he was talking about.

  10. #10
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,196
    +1
    38
    Quote Originally Posted by barefoot1 View Post
    I just pulled mine off Saturday to re-pack with grease. Both of my 04's are not threaded. However, I found water in the pump grease on one of them. Both O-rings were seated and appeared to be OK after inspection. Cone looks fine. Where else could this water be coming from? Bearings didn't show any rust but grease was grey from water contamination. Only run them in fresh water. Any help or ideas on how to keep this from happening again would be appreciated.

    pressure test them and look for a leak

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts 04 rxp pump cone x3
    By JamieCraigGreenfield in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 08-14-2014, 10:12 PM
  2. WTB 04 RXP Pump Shoe
    By Kidd800XP in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 02-12-2010, 05:48 PM
  3. FS: 04 rxp pump
    By rxp127 in forum Sea Doo Classifieds
    Replies: 8
    Last Post: 06-19-2009, 11:37 PM
  4. FS 04 RXP pump w/R&D auto drop and reverse bucket
    By RXPRacer513 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 05-09-2009, 09:07 AM
  5. RXPX impeller boot (rubber nose cone) removed...saltwater rider?
    By FrankieV123 in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-17-2009, 06:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •