Results 1 to 3 of 3
  1. #1

    Fuel pump in gp1300r not working?

    Anybody had this problem?

    2003 with 30 hours.


  2. #2

    Join Date
    Apr 2006
    Location
    Gore, New Zwaland
    Posts
    76
    Yes, I struck a new one recently that the plug on the top of the fuel tank was not pushed fully home. Lift the front locker box out, wriggle and push both the plugs until you hear a click. REXA.

  3. #3

    Join Date
    Apr 2006
    Location
    Gore, New Zwaland
    Posts
    76
    Yes, I struck a new one recently that the plug on the top of the fuel tank was not pushed fully home. Lift the front locker box out, wriggle and push both the plugs until you hear a click. REXA.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 09-06-2013, 10:40 PM
  2. 2000 RX Millenium Fuel gauge and Speedo not working...
    By Ski Hacks MG in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 05-16-2013, 11:43 PM
  3. fuel pump, change or not ?
    By m1dtom in forum 4-Tec Performance
    Replies: 1
    Last Post: 01-21-2010, 03:26 PM
  4. 2006 rxp fuel pump runs gauge wont work
    By pjsc823 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-21-2009, 09:21 PM
  5. 97 XPS Fuel gauge and Trim not working
    By jrea in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-09-2008, 07:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •