Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    GP1200R finally runs excellent

    Thanks to all that helped me get this thing running better than new!! It finally screams. Below is what I did which were all the correct things that were suggested from all of you on this site.

    *2000 GP1200R
    *New SBT motor with 4 hours
    *New Carb kits
    *Dplate
    *Riva Pump seal kit
    *Riva Intake grate
    *Solas 13/19
    *New Hydroturf
    *Riva Flame Arrestor kit with outerwears
    *Riva easy tune T-handle kit
    *1.5 N/S
    *95 gram spring
    *110 and 125 jets
    *1.5 turns out on high and 1 1/8 on low (smokes a little more so I may need to go in an 1/8th on low but it runs with no hesitation)
    *Chokes and accellerator pumps removed
    *Primer installed (installed lines in old oil pump inserts on carbs and it works great)
    *Oil block off kit
    *Wave eater couplers (should have gone w/ RPM but these seem to work good)
    *32:1 ratio
    *R&D extended Nozzle

    Fires right up and just screams on the water, engine only gets warm when run WOT for 3 minutes straight

    Any other suggestions?

    This site is simply the best because no mechanic (went thru 3) could figure out how to make this thing run absulutely perfect. I did it all myself with the help of SBT on the motor install and this site for all of the things that this engine needed. Thanks!!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	GP1200R Complete 001.jpg 
Views:	87 
Size:	725.2 KB 
ID:	121192   Click image for larger version. 

Name:	GP1200R Complete 002.jpg 
Views:	93 
Size:	705.4 KB 
ID:	121193   Click image for larger version. 

Name:	GP1200R Complete 003.jpg 
Views:	60 
Size:	693.5 KB 
ID:	121194   Click image for larger version. 

Name:	GP1200R Complete 004.jpg 
Views:	51 
Size:	650.0 KB 
ID:	121195  


  2. #2
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Glad to hear yu got it running well

  3. #3
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    looks good

    lets see some pics of the jetworks plumbing

    also, on that big black rubber coupler that goes from the U pipe to stinger... most usually rotate it around to where the pisser hose comes out at about 4:00 to 5:00 to clear for better carb adjustment

  4. #4
    Attached are pics of the Jetworks plumbing. This was pn the boat before I owned it. Not sure what this is for or if it is set up right. Also, how would moving the pisser hose allow for better carb adjustment?

    Thanks
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Jet works 001.jpg 
Views:	72 
Size:	740.0 KB 
ID:	121214   Click image for larger version. 

Name:	Jet works 002.jpg 
Views:	68 
Size:	712.0 KB 
ID:	121215   Click image for larger version. 

Name:	Jet works 003.jpg 
Views:	63 
Size:	705.4 KB 
ID:	121216  

  5. #5
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    jetworks looks good... just maybe go for a ride without the seat, and disconnect the feed hose (and hang out the side) to make sure water is coming out the valve around 3000rpms

    looks like you have your coupler boot hose coming over the front of the U-pipe rather than around the front of the motor
    I would be a little worried the cover might rub a hole in the hose

  6. #6
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    ^
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	GP1200R%20Complete%20001-2.JPG 
Views:	155 
Size:	561.9 KB 
ID:	121217  

  7. #7
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    If you have not done so already, I would also reinforce the pump tunnel.

  8. #8
    WFO: You say I should disconnect the white hose and see if water comes out of the Jetworks valve while connected to the black hose or disconnect from black hose to see if it is coming out of the white hose while connected to Jetworks valve? What happens if water is not coming out of the jetworks unit?

    RXP: I will search for reinforcing the pump housing because I have no idea how to do this.

    Thanks

  9. #9
    improvised tmg97gp's Avatar
    Join Date
    Jul 2008
    Location
    Midlothian Virginia USA ~ On the James River~
    Posts
    1,377
    +1
    10

    Thumbs up

    Looks Good!!

  10. #10
    Pistonwash's Avatar
    Join Date
    Aug 2005
    Location
    Florida
    Posts
    3,595
    +1
    77

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GP1200r First Run after Modifications [Help Plz]
    By Coveted in forum Yamaha PWC Performance (2-stroke)
    Replies: 74
    Last Post: 08-21-2016, 07:02 PM
  2. GP1200R was running excellent, Help??
    By Forest in forum Yamaha Open Discussion
    Replies: 30
    Last Post: 04-02-2009, 08:56 PM
  3. Finally running 90+ ! ! !
    By GeoRXT in forum Open Discussion
    Replies: 22
    Last Post: 06-09-2008, 02:44 PM
  4. Finally running 90+ ! ! !
    By GeoRXT in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-05-2008, 09:26 PM
  5. 2001 GP1200R Not Running Good... Help!
    By stepjl in forum Yamaha PWC Performance (2-stroke)
    Replies: 42
    Last Post: 09-30-2007, 06:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •