Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374

    Maiden run on efi tripple

    I made about 4 passes on my EFI tripple today, used the stock map for run.
    Keep in mind this is on a 0 hour engine running the map I used for the single pipe engine. Thought I have more fuel but almost run out before I could get back to the dock.
    [email protected]
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	100_0211.jpg 
Views:	63 
Size:	119.1 KB 
ID:	121251   Click image for larger version. 

Name:	100_0212.jpg 
Views:	62 
Size:	101.9 KB 
ID:	121252  


  2. #2
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Hows it pull? What prop?

  3. #3

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374
    pulls hard be need the change the map,cause it's too rich on acceleration
    I'm running a dynafly 14/20 I bought from a member here

  4. #4
    alex29573's Avatar
    Join Date
    Mar 2008
    Location
    miami
    Posts
    658
    +1
    1
    how did you get an EFI to rev that high?

  5. #5

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374
    with this
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	100_0214.jpg 
Views:	36 
Size:	71.1 KB 
ID:	121273  

  6. #6
    Pistonwash's Avatar
    Join Date
    Aug 2005
    Location
    Florida
    Posts
    3,595
    +1
    77
    Go get em' Mike!! Good progress for the first day!

    I know you know those pipes like 7750 and above...can you get to 8000 rpm's?? How in the heck did you by-pass the OEM e-box??

  7. #7
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23

    Thumbs up

    Way cool !!! is this the first EFI triple piper !!!
    yes, how did you get around the rev limiter

  8. #8

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374
    I'm using the Macboost ecu with a cdi module wired into the oem harness
    Set it up and Mapping it myself. Maybe I should call it the Mikeboost LOL

  9. #9
    Moderated
    Join Date
    Oct 2006
    Posts
    3,711
    sweet

    how hard has it been to get the ecu to this (workable) point and what has it cost in parts (ecu+cdi module+ harness+ time)?

  10. #10
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Anderson, Indiana
    Posts
    5,155
    +1
    170
    Wow....great numbers for a starting point!! I'm going to watch this thread to see how it turns out. Are you running the 3d key?

    M

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tripple Pipe on EFI
    By Chrisrokc in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-07-2007, 04:38 PM
  2. GP800 only running on one cylnder... why?
    By rnq124 in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 09-23-2006, 10:04 AM
  3. RED Pot on EFI
    By yamahajetpilot in forum Yamaha How To & FAQs
    Replies: 14
    Last Post: 08-18-2006, 02:27 AM
  4. I took the maiden voyage on the Green Hulk
    By Green Hulk in forum 4-Tec Performance
    Replies: 48
    Last Post: 05-16-2006, 08:59 AM
  5. ECU up and running on RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 15
    Last Post: 04-16-2006, 12:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •