Results 1 to 9 of 9
  1. #1
    AaronC's Avatar
    Join Date
    Aug 2006
    Location
    Sacramento, CA
    Posts
    457
    +1
    4

    Cool No speed gain with R&D plate & wedge?

    I just put my R&D plate on, with 1 degree wedge and even did the twin feed intercooler mod and gained NOTHING, WTF? I cleaned the silicone out of the pump tunnel, and took my time to make sure the ride plate fit correctly. It is slightly recessed into the hull. The ski felt good, but my RPM's were the same as last year (7820-7880) and the speeds were the same too. My wrist mount GPS is spot on with my speedo on the truck and my other garmin. R&D's web page says their kit does 70 and the rideplate is good for 3 mph of that gain. I gained about that on my 15f, but nothing on the Ultra. The ski is making full boost and runs good, but I don't understand my results?


  2. #2
    Doesnt seem rite hearing ti either. Something is a miss. Dont be bumbed if you dont get 3 mph but you should see at least a 1.5 to 2 mph easily.

    Let us know if its the prop or something. Did you do sponsons too or any other mods?

  3. #3
    AaronC's Avatar
    Join Date
    Aug 2006
    Location
    Sacramento, CA
    Posts
    457
    +1
    4
    No sponsons, but the handling did improve. I get 0 cavitation and the holeshot is strong. Something doesn't seem right The only other thing I did was the BOV breather kit.

  4. #4
    JET250's Avatar
    Join Date
    Jan 2008
    Location
    Australia mate fair dinkum.
    Posts
    1,278
    +1
    2
    block your bov and see if it gets better.

  5. #5
    halfassjack's Avatar
    Join Date
    May 2007
    Location
    Nicholasville, Ky.
    Posts
    549
    Did you test stock vs mods on the same day?

    David

  6. #6
    AaronC's Avatar
    Join Date
    Aug 2006
    Location
    Sacramento, CA
    Posts
    457
    +1
    4
    Quote Originally Posted by halfassjack View Post
    Did you test stock vs mods on the same day?

    David
    My previous testing was done while stock with the timing mod. So testing was not on the same day but similar conditions. The ski rides higher now compared to stock but not a huge difference in lift. The pics I've seen of others riding with the Riva plate and 2* wedge seem to be getting a lot more lift than I am. I've looked at other people's setups and some are running 8100-8200 RPMS with stock intake and exhaust. That's a far cry from my 7850 avg. Stock I was getting 7600-7650 and the timing mod gave me a steady 7850ish.

  7. #7
    MADRUI madrui's Avatar
    Join Date
    Oct 2008
    Location
    portugal-algarve
    Posts
    125
    riva and r&d are a litle different the riva lift more but less control

  8. #8
    sportman's Avatar
    Join Date
    Mar 2008
    Location
    Abu Dhabi-UAE
    Posts
    333
    Quote Originally Posted by AaronC View Post
    I just put my R&D plate on, with 1 degree wedge and even did the twin feed intercooler mod and gained NOTHING, WTF? I cleaned the silicone out of the pump tunnel, and took my time to make sure the ride plate fit correctly. It is slightly recessed into the hull. The ski felt good, but my RPM's were the same as last year (7820-7880) and the speeds were the same too. My wrist mount GPS is spot on with my speedo on the truck and my other garmin. R&D's web page says their kit does 70 and the rideplate is good for 3 mph of that gain. I gained about that on my 15f, but nothing on the Ultra. The ski is making full boost and runs good, but I don't understand my results?
    I have 07 Blue Ultra..see my modification list below..the gain was less that 2 miles
    I believe that in hot weather ultra perform not as i like it to perform

  9. #9

    Join Date
    May 2007
    Location
    Orange County, CA
    Posts
    201
    Ok, so I am about to get the R&D plate. I have seen some people say that the fit is ecxellent but the casting could be better. This got me to thinking about...I think his name was Jim, in Florida who reworked plates. However, at that time he was reworking the stock plates because the 250 was fairly new and there weren't many aftermarket parts available. Does anyone know if he is still doing this? If so, would it even be worth it to attempt to get anything else out of that plate. I think he was charging around $80, plus round trip shipping. I am wondering if it would be worth the money.

    thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Any speed gains with a modded/aftermarket water box?
    By Yellow93 in forum Yamaha PWC Performance (4-stroke)
    Replies: 15
    Last Post: 05-11-2013, 08:12 AM
  2. Mods but no speed gain
    By icdoo in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-16-2011, 07:07 AM
  3. No speed gain with mods
    By SplishSplash in forum 4-Tec Performance
    Replies: 24
    Last Post: 06-17-2010, 06:45 PM
  4. Speedfreek's Ride Plate Speed Gains on RXT
    By ramnj in forum 4-Tec Performance
    Replies: 9
    Last Post: 01-15-2008, 12:16 PM
  5. Need help with Yamaha Jet ski ... No speed
    By welterracer in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 03-19-2007, 10:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •