Results 1 to 2 of 2
  1. #1
    Center87's Avatar
    Join Date
    Aug 2008
    Vernon, B.C.

    Stalling and Hard Starting

    Hey Everyone,

    My Uncle owns a 2003 three seater Kawasaki 900xp, he has owned it for two years and it always took a long time to start, as time went on it took longer to start and now it stalls after running for 30 seconds. I have offered to try and help him and looking for some tips, I will be checking for spark and fuel but any other suggestions would be great.


  2. #2
    DPeteLand PeteSkeet's Avatar
    Join Date
    Jul 2008


    idk im just throwing in my two cents here...

    fuel pump


    carb(s) i beleive on the 900 there are 3...

    intake * part of your carbs *

    hmmm... fuel flow??

    possible too much oil flow

    things of that nature.. hope it help!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. starts right up then stalls, then hard start. but it will start.
    By 250super in forum Polaris Open Discussion
    Replies: 10
    Last Post: 09-05-2012, 09:27 AM
  2. 1997 SPX hard start and sluggish
    By Andrerichard in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-23-2009, 07:57 PM
  3. 99 XLT Stalls and takes a while to start
    By joeg12345 in forum Yamaha Open Discussion
    Replies: 14
    Last Post: 08-19-2009, 07:12 PM
  4. 96 SLX780 Rough Idle, Hard Start, and Miss
    By rickreeves1 in forum Polaris Open Discussion
    Replies: 23
    Last Post: 02-27-2008, 06:43 PM
  5. 04 Wake hard starting spits and sputters? Bad Gas/foulded plugs?
    By blandis in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-10-2007, 08:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts