Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30
  1. #1

    Join Date
    Sep 2007
    Location
    Byron, GA.
    Posts
    69

    xp800 backfire thru carbs

    Where do I start? The ski will run and rev up, but it backfires thru the exhaust and carb.


  2. #2
    rectifier

  3. #3
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Have you had the carbs off recently and the Rotary valve?

  4. #4

    Join Date
    Sep 2007
    Location
    Byron, GA.
    Posts
    69
    I just bought the ski the guy said it had not been ran in about six months. He also said it ran fine. I took it to the lake it backfired a little and took off. I rode for a minute and it cut off. it was hard to crank after that I then put it on the trailer. I backfires out the carb and exhaust. I cleaned the exhaust valves and put new plugs in it revs better, but still backfires. I have now pulled the the carbs off (not the RV cove) they had some trash and what could be water in them. Heck the carbs had some rust in them.

  5. #5
    If the carbs had rust in them, they need to be completely torn down and rebuilt. If not you will do engine damage. That may not even be your problem, but even if it isn't, it will be come one. I would start there.

  6. #6
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Normally a lean fuel mixture or flooded carbs doesn't cause backfires. Did you inspect the 3/8" oil line below the intake to make sure there is oil in it? I'm suspicious the brass RV gear is stripped on the RV shaft.

  7. #7

    Join Date
    Sep 2007
    Location
    Byron, GA.
    Posts
    69
    checked grounds, cleaned carbs, new plugs, and cleanded exhaust valves. Cranks up revs up fine, but backfires thru carbs and exhaust. It idles fine too. WTH.

  8. #8
    2Blue's BFF! dsolie's Avatar
    Join Date
    Apr 2007
    Location
    Olympia, WA
    Posts
    832
    +1
    1
    Disconnect your rectifier, see if that solves it..

    If not, then your rotary gear is probably bad (new crank)

  9. #9

    Join Date
    Sep 2007
    Location
    Byron, GA.
    Posts
    69
    Disconnected the rectifier, still did it. Checked oil line & there is oil in it.

  10. #10

    Join Date
    Sep 2007
    Location
    Byron, GA.
    Posts
    69
    96XPSS We are in the same town. Small world.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Seadoo GTX Backfiring after Carb Rebuild
    By JukeboxRob in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-22-2011, 10:08 AM
  2. 701 raider backfiring thru crank seal
    By flyingpiggy in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 03-03-2010, 08:11 PM
  3. 97 xp backfires thru the carbs
    By jared427 in forum 2-Stroke Performance
    Replies: 6
    Last Post: 07-28-2009, 07:11 AM
  4. 2003 GTI (717) Backfiring through Carb
    By steelroe in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 09-30-2008, 03:01 PM
  5. Fuel spitting back thru carb
    By fullshift in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-04-2008, 11:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •